camel-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From conflue...@apache.org
Subject [CONF] Apache Camel > Camel jar dependencies
Date Wed, 17 Aug 2011 09:50:00 GMT
<html>
<head>
    <base href="https://cwiki.apache.org/confluence">
            <link rel="stylesheet" href="/confluence/s/2042/9/1/_/styles/combined.css?spaceKey=CAMEL&amp;forWysiwyg=true"
type="text/css">
    </head>
<body style="background: white;" bgcolor="white" class="email-body">
<div id="pageContent">
<div id="notificationFormat">
<div class="wiki-content">
<div class="email">
    <h2><a href="https://cwiki.apache.org/confluence/display/CAMEL/Camel+jar+dependencies">Camel
jar dependencies</a></h2>
    <h4>Page <b>edited</b> by             <a href="https://cwiki.apache.org/confluence/display/~davsclaus">Claus
Ibsen</a>
    </h4>
        <br/>
                         <h4>Changes (4)</h4>
                                 
    
<div id="page-diffs">
                    <table class="diff" cellpadding="0" cellspacing="0">
    
            <tr><td class="diff-snipped" >...<br></td></tr>
            <tr><td class="diff-unchanged" >- activation-1.1.jar - For Attachments
support - Is provided in the JDK core from Java 1.6 onwards <br> <br></td></tr>
            <tr><td class="diff-changed-lines" >h4. camel-core dependencies for
Camel 2.7 <span class="diff-deleted-words"style="color:#999;background-color:#fdd;text-decoration:line-through;">onwards</span>
<span class="diff-added-words"style="background-color: #dfd;">- 2.8</span> <br></td></tr>
            <tr><td class="diff-unchanged" >- slf4j-api-1.5.11.jar - API for slf4j
logging <br>- commons-management-1.0.jar - API for JMX <br> <br></td></tr>
            <tr><td class="diff-added-lines" style="background-color: #dfd;">h4.
camel-core dependencies for Camel 2.9 onwards <br>- slf4j-api-1.6.1.jar - API for slf4j
logging <br> <br></td></tr>
            <tr><td class="diff-changed-lines" >h4. Optional dependencies for
JMX <span class="diff-added-words"style="background-color: #dfd;">for Camel 1.x - 2.8</span>
<br></td></tr>
            <tr><td class="diff-unchanged" >- spring-core.jar, spring-beans.jar,
spring-context.jar, spring-aop.jar - All 4 jars needed to use JMX with Camel (subject to change
in the future). <br> <br></td></tr>
            <tr><td class="diff-added-lines" style="background-color: #dfd;">From
*Camel 2.9* onwards the Spring JARs is no longer required for using JMX.  <br> <br></td></tr>
            <tr><td class="diff-unchanged" >h2. Other Components <br> <br></td></tr>
            <tr><td class="diff-snipped" >...<br></td></tr>
    
            </table>
    </div>                            <h4>Full Content</h4>
                    <div class="notificationGreySide">
        <h2><a name="Cameljardependencies-Cameljardependencies"></a>Camel
jar dependencies</h2>

<p>Camel core itself is lightweight and can run with a few .jars.</p>

<h4><a name="Cameljardependencies-camelcoredependenciesforCamel2.0orlower"></a>camel-core
dependencies for Camel 2.0 or lower</h4>
<ul class="alternate" type="square">
	<li>commons-logging-api.jar - API for commons logging</li>
	<li>JAXB 2.1.x - XML stuff - Is provided in the JDK core from Java 1.6 onwards</li>
	<li>activation.jar - For Attachments support - Is provided in the JDK core from Java
1.6 onwards</li>
</ul>


<h4><a name="Cameljardependencies-camelcoredependenciesforCamel2.12.6"></a>camel-core
dependencies for Camel 2.1 - 2.6 </h4>
<ul class="alternate" type="square">
	<li>commons-logging-api-1.1.jar - API for commons logging</li>
	<li>commons-management-1.0.jar - API for JMX</li>
	<li>JAXB 2.1.x - XML stuff - Is provided in the JDK core from Java 1.6 onwards</li>
	<li>activation-1.1.jar - For Attachments support - Is provided in the JDK core from
Java 1.6 onwards</li>
</ul>


<h4><a name="Cameljardependencies-camelcoredependenciesforCamel2.72.8"></a>camel-core
dependencies for Camel 2.7 - 2.8 </h4>
<ul class="alternate" type="square">
	<li>slf4j-api-1.5.11.jar - API for slf4j logging</li>
	<li>commons-management-1.0.jar - API for JMX</li>
</ul>


<h4><a name="Cameljardependencies-camelcoredependenciesforCamel2.9onwards"></a>camel-core
dependencies for Camel 2.9 onwards</h4>
<ul class="alternate" type="square">
	<li>slf4j-api-1.6.1.jar - API for slf4j logging</li>
</ul>


<h4><a name="Cameljardependencies-OptionaldependenciesforJMXforCamel1.x2.8"></a>Optional
dependencies for JMX for Camel 1.x - 2.8</h4>
<ul class="alternate" type="square">
	<li>spring-core.jar, spring-beans.jar, spring-context.jar, spring-aop.jar - All 4 jars
needed to use JMX with Camel (subject to change in the future).</li>
</ul>


<p>From <b>Camel 2.9</b> onwards the Spring JARs is no longer required for
using JMX. </p>

<h2><a name="Cameljardependencies-OtherComponents"></a>Other Components</h2>

<p>All the other <a href="/confluence/display/CAMEL/Components" title="Components">Components</a>
have a range of 3rd party .jars they depend on. They are listed in the maven pom files which
files they require.</p>
    </div>
        <div id="commentsSection" class="wiki-content pageSection">
        <div style="float: right;">
            <a href="https://cwiki.apache.org/confluence/users/viewnotifications.action"
class="grey">Change Notification Preferences</a>
        </div>
        <a href="https://cwiki.apache.org/confluence/display/CAMEL/Camel+jar+dependencies">View
Online</a>
        |
        <a href="https://cwiki.apache.org/confluence/pages/diffpagesbyversion.action?pageId=9012252&revisedVersion=4&originalVersion=3">View
Changes</a>
                |
        <a href="https://cwiki.apache.org/confluence/display/CAMEL/Camel+jar+dependencies?showComments=true&amp;showCommentArea=true#addcomment">Add
Comment</a>
            </div>
</div>
</div>
</div>
</div>
</body>
</html>

Mime
View raw message