calcite-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jh...@apache.org
Subject [4/7] calcite git commit: [CALCITE-1715] Downgrade to Guava 19.0 to fix Cassandra incompatibility
Date Tue, 21 Mar 2017 02:01:52 GMT
[CALCITE-1715] Downgrade to Guava 19.0 to fix Cassandra incompatibility


Project: http://git-wip-us.apache.org/repos/asf/calcite/repo
Commit: http://git-wip-us.apache.org/repos/asf/calcite/commit/1e405d63
Tree: http://git-wip-us.apache.org/repos/asf/calcite/tree/1e405d63
Diff: http://git-wip-us.apache.org/repos/asf/calcite/diff/1e405d63

Branch: refs/heads/branch-1.12
Commit: 1e405d63e6a25d3411ecc0cfe8f13f0c5d30068a
Parents: 5ee4378
Author: Michael Mior <mmior@uwaterloo.ca>
Authored: Mon Mar 20 16:59:49 2017 -0400
Committer: Michael Mior <mmior@uwaterloo.ca>
Committed: Mon Mar 20 16:59:49 2017 -0400

----------------------------------------------------------------------
 pom.xml | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/calcite/blob/1e405d63/pom.xml
----------------------------------------------------------------------
diff --git a/pom.xml b/pom.xml
index f93f80e..51fbab5 100644
--- a/pom.xml
+++ b/pom.xml
@@ -55,7 +55,7 @@ limitations under the License.
     <airlift-tpch.version>0.1</airlift-tpch.version>
     <avatica.version>1.9.0</avatica.version>
     <build-helper-maven-plugin.version>1.9</build-helper-maven-plugin.version>
-    <cassandra-driver-core.version>3.0.0</cassandra-driver-core.version>
+    <cassandra-driver-core.version>3.1.4</cassandra-driver-core.version>
     <checksum-maven-plugin.version>1.2</checksum-maven-plugin.version>
     <commons-dbcp.version>1.4</commons-dbcp.version>
     <commons-lang3.version>3.2</commons-lang3.version>
@@ -72,7 +72,7 @@ limitations under the License.
     <!-- We support (and test against) Guava versions between
          14.0.1 (Hive) and 21.0 (most recent; supports only JDK8 and up).
          Override with your preferred version and it should work. -->
-    <guava.version>20.0</guava.version>
+    <guava.version>19.0</guava.version>
     <joda.version>2.8.1</joda.version>
     <h2.version>1.4.185</h2.version>
     <hadoop.version>2.7.0</hadoop.version>


Mime
View raw message