buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Donald <>
Subject Re: "package :sources" not compatible with maven repository
Date Thu, 31 Oct 2013 22:42:19 GMT

On Fri, Nov 1, 2013 at 7:19 AM, Chris Bozic <> wrote:
> ruby 2.0.0p247 (2013-06-27 revision 41674) [x86_64-darwin12.3.0]
> buildr 1.4.12

Okay - so the problem is specifically the version of Buildr in use. In
version 1.4.13, we fixed several bugs relating to 2.0.0 and added ruby
2.0 to the list of rubies that we test the ci against. If you can
upgrade to a later version then that may work. However if you want to
wait for the next release then you should be able to use a patch such
as something like (Note I have not  tested this but it should work,
holler if it does not).

class Buildr::Project
  def package_as_sources_spec(spec) #:nodoc:
    spec.merge(:type => :jar, :classifier => 'sources')

  def package_as_javadoc_spec(spec) #:nodoc:
    spec.merge(:type => :jar, :classifier => 'javadoc')
end unless Buildr::VERSION > '1.4.12'


Peter Donald

View raw message