buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Boisvert <>
Subject Re: basic question about using Apache Buildr
Date Sun, 22 May 2011 17:12:10 GMT
2011/5/21 王雷 <>

>    Thanks for the fast reply.   How to figure out the version requirement
> is less than 1.5.0. Is there any document specify this? Thanks again.

Requirements such as "~>1.4.3" as used to allow any minor version upgrade
(e.g. bug fixes) but not allow major version changes that may involve some
non-backward-compatible changes.

Case in point:  Buildr 1.5.0 does not exist but it's possible we'll make
changes that could break some buildfiles.  (We try not to do that often, but
it's possible).

So "~>1.4.3" is a middle ground between fixed version (too strict) and
allowing any new version (too flexible).  It allows for minor upgrades that
could fix potential issues not currently known (e.g. platform-specific
issues, dependency evolution, and so on).


  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message