buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ed Smiley <>
Subject Re: Authenticated access to maven repo
Date Fri, 27 Aug 2010 15:52:59 GMT
If you want to use sftp, there's a fix in the next release that makes it
work correctly.  (It's documented, but doesn't yet work.)

2010/8/26 Khristian Alexander Schönrock <>

> Update:
> I found some messages about patches enabling basic auth in http access with
> Buildr, but I couldn't find how to do it anywhere.
> I did, however, stumble upon this line in a changelog:
> "request.should_receive(:basic_auth).with('john', 'secret')
> URI("http://john:secret@#{@host_domain}").read end"
> So I tried, in my repositories line, the following:
> repositories.remote << URI.parse("http://user:pass@repo.url..."). And it
> worked!
> I hope this helps someone else, because I feel pretty dumb here :)
> -----Original Message----- From: Khristian Alexander Schönrock
> Sent: Tuesday, August 24, 2010 1:57 PM
> To:
> Subject: Authenticated access to maven repo
>  Hello,
> I'm trying out Buildr for some of my company's projects, and I'm already
> speeding up some previously tedious tasks (at least packaging, so far).
> For these tasks, I need to access our maven repo to download artifacts,
> but I didn't have much success so far. Our repository manager (archiva)
> only listens to secure connections(https), but, from what I see printed
> in the output, Buildr converts them to regular HTTP.
> The output contains this: "Failed to download
> http://repo-url/archiva/repository/snapshots/[path-to-artifact].jar<http://repo-url/archiva/repository/snapshots/%5Bpath-to-artifact%5D.jar>
> :
> Unauthorized
> Buildr aborted!"
> How do I specify these settings? Also, how can I import these settings
> from my maven settings.xml file?
> Thanks in advance,
> Khristian Schönrock

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message