buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Will Rogers <>
Subject Re: rjb-1.1.9 does not build on Windows with JDK in default location
Date Sun, 20 Dec 2009 00:07:34 GMT
On Thu, Dec 17, 2009 at 1:43 PM, Assaf Arkin <> wrote:
> I think they're just using a different platform identifier, because their
> suggestion is:
> gem install --platform=mswin32

Thanks for clarifying the problem. To follow up, I can confirm that
buildr installs and works with:

    gem install buildr --platform mswin32

Maybe that's what you should put in your installation guide? Contrary
to what I said in my first mail, with this fix the ruby installer
devkit is not necessary because rubygems installs the binary gems as
you intended. It might also be worth mentioning that you need Ruby
1.8, not Ruby 1.9, because the ruby installer page lists both without
guidance. Users might tend to choose the higher number ;)

-- Will

View raw message