buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Doug Farmer <doug4...@gmail.com>
Subject Re: Cobertura issue
Date Tue, 09 Jun 2009 21:42:51 GMT
Daniel,

The issue is filed under BUILDR-285.

Thanks,
Doug Farmer


On Tue, Jun 9, 2009 at 5:29 PM, Daniel Spiewak <djspiewak@gmail.com> wrote:

> This sounds like a bug to me.  Could you file as an issue please?
> http://issues.apache.org/jira/browse/Buildr  I think I have an idea of
> what
> might be wrong, so I'll take a look at it asap.
>
> Daniel
>
> On Tue, Jun 9, 2009 at 4:07 PM, Doug Farmer <doug4641@gmail.com> wrote:
>
> > Hello,
> >
> > I'm running into a problem when I try to run cobertura report generation
> > during a build. I receive the following error stating, "Error: data file
> > C:\Dev\Components\reports\cobertura.ser does not exist".
> >
> > Here's the basic structure of my build file.
> >
> > desc "Components"
> > define "components" do
> >
> >    desc "Some Component"
> >    define "someComponent" do
> >    <build this component>
> >    end
> >
> > end
> >
> > Since no code actually exists in the *components* project there isn't a
> > need
> > to run or create any reports. If I execute *buildr test
> > components:someComponent:cobertura:html* on the command line everything
> > works fine because I'm specifying a specific the project I want to build
> > and
> > generate reports. If I excute *buildr test cobertura:html* on the command
> > line I get the above error.
> >
> > Has anyone come across this problem or can point out to me what I may be
> > doing wrong. The buildr documentation doesn't seem to be very helpful and
> > I'm kind of at a loss.
> >
> > Thanks in advance for you help.
> >
> > Doug
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message