buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Boisvert <>
Subject Re: build.yaml issue
Date Thu, 07 May 2009 19:03:44 GMT
This works for me... and we also have tests (specs) for this so I'm thinking
it's a user error.

You may want to try:

puts " #{}"

to see the content of the loaded build.yaml and see if the 'project'
property is defined.

If you're still not getting what you want, send the content of your


On Wed, May 6, 2009 at 12:12 PM, <> wrote:

> Hello,
> I'm experiencing some issues with buildr. I have specified at build.yaml
> file in the same directory as my buildfile.rb but when I try to reference it
> in my buildfile it is does not get loaded. Currently, the only file that I
> am able to reference is the settings.yaml file in the userhome/.buildr
> directory. I also tried creating a profiles.yaml file and that too is not
> referencable from within the buildfile. Has anyone experience this issue?
> Here's a snippet of my buildfile.
> ENV['JAVA_OPTS'] ||= '-Xms512m -Xmx512m'
> require 'buildr'
> imSettings = Buildr.settings.user['insight_manager']
> raise 'You did not correctly setup your %USERPROFILE%/.buildr/settings.yaml
> file' unless imSettings
> buildSettings =['project']
> raise 'Could not find the build.yaml file!' unless buildSettings
> I've read the documentation on the website and I thinking I'm doing
> everything right. The only thing I can think of is that there is a path
> issue but I can't seem to find one.
> If you have any insight into what the problem might be I would greatly
> appreciate it!
> Doug

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message