buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Assaf Arkin" <>
Subject Re: Installing Buildr on Solaris
Date Tue, 14 Oct 2008 16:12:35 GMT
On Tue, Oct 14, 2008 at 8:34 AM, rp.andrew.moore
<> wrote:
> Thanks Ittay...
> I'm realizing my problem seems to be in the ruby-java-bridge (rjb-1.1.2)
> dependency. I seem to have installed ruby and rubygems successfully using
> pkg-get from
> Then I try installing buildr via gems and in the process it tries to install
> the rjb dependency (it wants version 1.1.2 for some reason). RJB fails to
> compile locally...

We're heading for a new release, which will use RJB 1.1.6, I would
recommend looking at 1.1.6 first.  Once you gem install rjb, even
partially, it places all the necessary files in your gem directory,
giving you a change to try and compile it manually; specifically
you're looking for files in the ext directory which contain the build
script (extconf.rb), make file, C files, etc.

Most likely, it will have a problem compiling against the JNI headers
(or finding them to begin with).


> I think my next best shot is to try and build and install rjb from source or
> something. Any other ideas?
> Thanks!
> ~ Andrew
> --
> View this message in context:
> Sent from the Apache Buildr - User mailing list archive at

View raw message