buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gayard, Leonel" <>
Subject RE: Facing bug BUILDR-82 on Buildr-1.3.2. (Wasn't this fixed ?)
Date Fri, 08 Aug 2008 14:06:53 GMT
According to the jruby-openssl project page [1], Net::SSH does not work in JRuby.

The solution might be for Buildr not to require it at all, but I guess this will take some
time to patch.

As a quick and dirty solution, I edited file buildr/core/transports.rb removing the lines
"require 'net/ssh'" and "require 'net/sftp'" and the monkey-patch to module Net.

With that in place, I successfully created a build file, but I only went so far. I'll try
some more later and post my results here.



-----Original Message-----
From: Assaf Arkin []
Sent: Thu 07/08/2008 18:37
Subject: Re: Facing bug BUILDR-82 on  Buildr-1.3.2. (Wasn't this fixed ?)
On Aug 7, 2008, at 4:42 AM, Gayard, Leonel wrote:

> Hi.
> Newbie here. JRuby 1.1.3, WinXP, JDK1.6.0_02
> Just installed Buildr 1.3.2, via clean gem install. Still, I'm facing
> bug BUILDR-82, related to Net::SSH not being nice to JRuby on WinXP,
> as explained by Assaf:
> The bug is marked as fixed for version 1.3.2, so I'm surprised to be
> facing it.
> BTW, is version 1.3.2 released ? It shows up on the website, and the
> gem install works right out of the box, but I do not see a tag for
> 1.3.2 in the SVN repo at

Released, but the tag is indeed missing, so I recreated it.  Thanks  
for pointing that out.

> Now, I'm a newbie, so I don't really understand the workaround
> suggested by Assaf of adding Net::SSH to $LOAD_PATH. Can someone
> explain how to do this ?

Well, I found out the problem with that, net/ssh/authentication/ 
pageant should be added to LOADED_FEATURES, not LOAD_PATH.

Updating SVN with this fix.


> Thanks a lot
> []'s
> Leonel

  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message