buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephen Bannasch <stephen.banna...@deanbrook.org>
Subject Re: problems installing buildr JRuby trunk on MacOS 10.5.3
Date Fri, 04 Jul 2008 20:53:24 GMT
At 8:31 AM -0700 7/1/08, Assaf Arkin wrote:
>On Sun, Jun 29, 2008 at 12:47 PM, Assaf Arkin <arkin@intalio.com> wrote:
>> On Sat, Jun 28, 2008 at 10:34 PM, Stephen Bannasch
>> <stephen.bannasch@deanbrook.org> wrote:
>>> This is using trunk JRuby (r7043) which is now using rubygems 1.1.2
>>>
>>> [jruby.git (work)]$ jruby -S gem install buildr
>>> JRuby limited openssl loaded. gem install jruby-openssl for full support.
>>> http://wiki.jruby.org/wiki/JRuby_Builtin_OpenSSL
>>> ERROR:  Error installing buildr:
>>>        buildr requires net-ssh (= 2.0.1, runtime)
>>
>> That's strange.  You get this error message because RubyGems knows it
>> needs net-ssh to install Buildr, so it determines the dependencies
>> correctly, but reports that it can't find net-ssh 2.0.1 anywhere.  But
>> then when you try to install net-ssh, no problem.  I'm guessing
>> something in RubyGems 1.2.0 that doesn't like JRuby?
>
>I just read that this is a known problem with RubyGems 1.2.0, has
>nothing to do with JRuby specifically, no explanation how to correct
>it, though.
>
>Assaf

Yes. I does not affect all gems however and is not limited to jruby.

For example rails dependencies still work find in jruby and mri while sake doesn't load it's
dependencies in mri.

fyi: Bug report on rubgems bugtracker:

http://rubyforge.org/tracker/index.php?func=detail&aid=21056&group_id=126&atid=575

Mime
View raw message