buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Assaf Arkin" <ar...@intalio.com>
Subject Getting around Error installing buildr: buildr requires ...
Date Tue, 22 Jul 2008 19:44:42 GMT
If you're trying to gem install buildr you might get an error like this:

ERROR:  Error installing buildr:
        buildr requires hoe (= 1.6.0, runtime)

This happens for some dependencies, and apparently only if you
upgraded to RubyGems 1.2.0, including the just released JRuby 1.1.3.
This looks like a RubyGems bug [1], so there's nothing we can do to
fix it but wait for a new RubyGems release.

Meanwhile, the quick work around is to manually install the specific
dependencies Buildr complains about (most dependencies will install
fine on their own), for example:

  gem install hoe -v 1.6.0

Make sure to use the same version number that shows in the error
message.  This error only happens if Buildr needs an older version of
the dependency and a newer version was released through RubyForge.

Assaf

[1] http://rubyforge.org/tracker/index.php?func=detail&aid=21056&group_id=126&atid=575

Mime
View raw message