buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tomas Carlsson" <>
Subject Re: buildr on jruby and windows, sort of success.
Date Sun, 06 Apr 2008 15:58:23 GMT
(sorry for breaking the thread, I'm now subscribed to the list.)

>>  * "jruby -S rake setup" does not work because "sudo" is called in the
>> install command. So I manually installed the deps listed in Rakefile
>> -S gem install ...).
>Fixed rake setup, tested with a fresh JRuby 1.1 ;)

Now I get this:

       C:\src\buildr-trunk\buildr>jruby -S rake setup
       (in C:/src/buildr-trunk/buildr)
       Please run rake setup to install the Docter document generation
       rake aborted!
       getuid unsupported on this platform

I get the same for "jruby -S rake install". The docter line appears even if
the docter gem is installed.

>>  * "jruby -S rake spec" fails on
>>         ./spec/application_spec.rb:279:in `describe': can't convert
>> into String (TypeError)
>>     but it seems you dont _have_ to run the tests.
>Fixed application_spec.rb on trunk

This gets further now, but not completely working. I guess the problem is
that we try to run "ruby" instead of "jruby", however I have no clue to
where this is done...

←[32m- should ignore classes not using TestNG annotations←[0m
[Parser] Running:

Total tests run: 0, Failures: 0, Skips: 0

rake aborted!
Command ruby -I"C:/sw/jruby-1.1/lib/ruby/gems/1.8/gems/rspec-1.1.3/lib"
ruby-1.1/lib/ruby/gems/1.8/gems/rspec-1.1.3/bin/spec" "spec/addon_spec.rb"
/application_spec.rb" "spec/archive_spec.rb"
"spec/artifact_namespace_spec.rb" "
spec/artifact_spec.rb" "spec/build_spec.rb" "spec/checks_spec.rb"
pec.rb" "spec/compile_spec.rb" "spec/groovy_compilers_spec.rb"
ameworks_spec.rb" "spec/java_compilers_spec.rb"
"spec/java_packaging_spec.rb" "s
pec/java_test_frameworks_spec.rb" "spec/packaging_spec.rb"
" "spec/scala_compilers_spec.rb" "spec/test_spec.rb"
"spec/transport_spec.rb" "s
pec/version_requirement_spec.rb" --options spec/spec.opts --format
les:failing failed

>> This worked for me. Now I just have to check that buildr trunk on jruby
>> works with my projects :-)
>Again, thanks for trying Buildr, we welcome any comment or issue you may
> find, we need more users/developers running Windows ;)

Although I prefer Linux as development platform I'm stuck on Windows for now
so I'll do what I can to help. I will probably be a user rather than
developer since my Ruby skills are not very high (yet...).


  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message