buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From dhpeterson <>
Subject Zip task not respecting file permissions?
Date Tue, 29 Jan 2008 23:25:49 GMT

Hi all,

I'm packaging up various components in a ZIP archive and I've noticed that
my execute bit (755) file permissions keep getting stripped from files
during the zip step. Has anyone else noticed this behaviour?

Specifically, I have tried two ways:

1. Direct include of mode-x (755) files

I have some resources (script files) sitting in a sub-directory of my
resources/ path. When I package them into a zip file using the below task,
the executable bit permissions are lost.

  package(:zip).include _("src/main/resources/etc/*"), :path =>

2. Merge of a ZIP file containing correct file permissions

I made a "" file containing a "blah/" directory which had certain
files that were executable. I then merged this zip against my main zip file
to produce a resultant file using the task:

  package(:zip).merge("", :path => "#{id}-#{version}/.")

When I re-opened file resultant ZIP file and navigated to the blah/
directory, the file permissions of the files within this directory have
reverted to 644.

I've tried a couple of ways now and I keep meeting the same issue. I have
set svn:executable property onto each of the files, and it didn't make any

Is this a bug in the implementation of the Zip task? Help/guidance
appreciated (as always). If it is a bug, I am happy to raise an issue/report
in JIRA. Just let me know.


View this message in context:
Sent from the Buildr - User mailing list archive at

View raw message