buildr-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antoine Toulme (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (BUILDR-713) option --buildfile has different behaviour when folder is changed
Date Tue, 16 Aug 2016 17:11:20 GMT

    [ https://issues.apache.org/jira/browse/BUILDR-713?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15423072#comment-15423072
] 

Antoine Toulme commented on BUILDR-713:
---------------------------------------

I reproduce the issue. Thanks for reporting this bug. I am working on this.

> option --buildfile has different behaviour when folder is changed
> -----------------------------------------------------------------
>
>                 Key: BUILDR-713
>                 URL: https://issues.apache.org/jira/browse/BUILDR-713
>             Project: Buildr
>          Issue Type: Bug
>          Components: Core features
>    Affects Versions: 1.4.25
>         Environment: Ubuntu 14.04
> ruby --version : ruby 1.9.3p484 (2013-11-22 revision 43786) [x86_64-linux]
> buildr --version : Buildr 1.4.25
>            Reporter: Sergio Morales
>            Assignee: Antoine Toulme
>             Fix For: 1.5
>
>
> If I have a project in directory "my-app" and I execute:
> {code}
> $ buildr test
> (in /home/sergio/Downloads/my-app, development)
> Testing my-app
> Compiling my-app into /home/sergio/Downloads/my-app/target/classes
> Compiling my-app:test into /home/sergio/Downloads/my-app/target/test/classes
> Running tests in my-app
> Trying to override old definition of datatype junit
>     [junit] Testsuite: com.company.project.HelloWorldTest
>     [junit] Tests run: 1, Failures: 0, Errors: 0, Time elapsed: 0.048 sec
>     [junit] 
>     [junit] Testcase: test took 0.002 sec
> Completed in 1.531s
> {code}
> That result is correct!, BUT if I go to parent directory (or any other directoy) and
execute:
> {code}
> $ buildr --buildfile my-app/buildfile test
> (in /home/sergio/Downloads, development)
> Testing my-app
> Completed in 0.010s
> {code}
> As you can see I don't have output about the result of the testing anymore.
> I consider it a bug because that difference of behavior is suspicious and in my case
undesirable. 
> Note: There is a workaround?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message