buildr-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antoine Toulme (JIRA)" <j...@apache.org>
Subject [jira] [Assigned] (BUILDR-693) Selection of Scalatest jar is inadequate and doesn't work with Scala 2.10
Date Fri, 20 May 2016 07:27:12 GMT

     [ https://issues.apache.org/jira/browse/BUILDR-693?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Antoine Toulme reassigned BUILDR-693:
-------------------------------------

    Assignee: Antoine Toulme

> Selection of Scalatest jar is inadequate and doesn't work with Scala 2.10
> -------------------------------------------------------------------------
>
>                 Key: BUILDR-693
>                 URL: https://issues.apache.org/jira/browse/BUILDR-693
>             Project: Buildr
>          Issue Type: Bug
>          Components: Test frameworks
>    Affects Versions: 1.4.14
>            Reporter: Rick Beton
>            Assignee: Antoine Toulme
>            Priority: Minor
>             Fix For: 1.5
>
>
> tests.rb includes code that determines its behaviour according to the Scala version in
use. The Scalatest jar dependency is hard-wired to an old version.
> So suppose I want to use scalatest_2.10-1.9.2.jar, I can't.
> A simple work-around in tests.rb around line 92 would be to expand it to
>     VERSION = case
>       when Buildr::Scala.version?(2.7)
>         '1.3'
>       when Buildr::Scala.version?(2.9)
>         '1.8'
>       else
>         '1.9.2'
>     end
> This would help me right now, but simply postpones the problem.
> A better solution might be to detect scalatest.jar on the dependencies for test and not
use a default unless scalatest was missing. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message