buildr-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Peter Donald (JIRA)" <j...@apache.org>
Subject [jira] [Reopened] (BUILDR-705) Remove runtime dependency on rspec
Date Sat, 28 Feb 2015 09:31:05 GMT

     [ https://issues.apache.org/jira/browse/BUILDR-705?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Peter Donald reopened BUILDR-705:
---------------------------------

> Remove runtime dependency on rspec
> ----------------------------------
>
>                 Key: BUILDR-705
>                 URL: https://issues.apache.org/jira/browse/BUILDR-705
>             Project: Buildr
>          Issue Type: Bug
>          Components: Dependency management
>    Affects Versions: 1.4.20
>         Environment: OS X 10.10
>            Reporter: r6p
>            Assignee: Peter Donald
>             Fix For: 1.4.21
>
>         Attachments: 0001-Removing-runtime-dependency-on-rspec.patch
>
>
> Having rspec as a "runtime dependency" for buildr is blocking us from updating rspec.
Since using buildr's rspec support is optional and we don't use it, but use rspec directly
ourselves this prevents us from upgrading rspec in our codebase due to version conflicts since
we include buildr in our Gemfile.
> I think it makes sense to ask users to include rspec separately in their Gemfile and
control the correct version required to make use of buildr's rspec support if that want to
use that feature of buildr. But this shouldn't block those of us who don't use buildr from
upgrading our independent rspec dependencies.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message