buildr-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From dona...@apache.org
Subject [2/3] buildr git commit: Update the gwt addon to add the validation dependencies required for GWT compiles without requiring that the user specify the dependency.
Date Thu, 13 Nov 2014 22:24:29 GMT
Update the gwt addon to add the validation dependencies required for GWT compiles without requiring
that the user specify the dependency.


Project: http://git-wip-us.apache.org/repos/asf/buildr/repo
Commit: http://git-wip-us.apache.org/repos/asf/buildr/commit/846fbc7f
Tree: http://git-wip-us.apache.org/repos/asf/buildr/tree/846fbc7f
Diff: http://git-wip-us.apache.org/repos/asf/buildr/diff/846fbc7f

Branch: refs/heads/master
Commit: 846fbc7f0f49385bf4deeb183cbcf1b350aeea73
Parents: 80dc1a7
Author: Peter Donald <peter@realityforge.org>
Authored: Fri Nov 14 09:23:09 2014 +1100
Committer: Peter Donald <peter@realityforge.org>
Committed: Fri Nov 14 09:23:09 2014 +1100

----------------------------------------------------------------------
 CHANGELOG           | 2 ++
 addon/buildr/gwt.rb | 6 ++++--
 2 files changed, 6 insertions(+), 2 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/buildr/blob/846fbc7f/CHANGELOG
----------------------------------------------------------------------
diff --git a/CHANGELOG b/CHANGELOG
index e6d3a6b..f0a5738 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,4 +1,6 @@
 1.4.21 (Pending)
+* Change: Update the gwt addon to add the validation dependencies required for GWT
+          compiles without requiring that the user specify the dependency.
 * Change: Update ipr.add_gwt_configuration method to support GWT 2.7 configuration
           parameters and IDEA 14 parameters.
 * Change: Upgrade jacoco to 0.7.2. Submitted by neher.

http://git-wip-us.apache.org/repos/asf/buildr/blob/846fbc7f/addon/buildr/gwt.rb
----------------------------------------------------------------------
diff --git a/addon/buildr/gwt.rb b/addon/buildr/gwt.rb
index 371f21d..506706e 100644
--- a/addon/buildr/gwt.rb
+++ b/addon/buildr/gwt.rb
@@ -28,15 +28,17 @@ module Buildr
 
       # The specs for requirements
       def dependencies(version = nil)
+        validation_deps =
+          %w(javax.validation:validation-api:jar:1.0.0.GA javax.validation:validation-api:jar:sources:1.0.0.GA)
         v = version || self.version
         gwt_dev_jar = "com.google.gwt:gwt-dev:jar:#{v}"
         if v <= '2.6.1'
-          [gwt_dev_jar]
+          [gwt_dev_jar] + validation_deps
         else
           [
             gwt_dev_jar,
             'org.ow2.asm:asm:jar:5.0.3'
-          ]
+          ] + validation_deps
         end
       end
 


Mime
View raw message