buildr-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Peter Donald (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (BUILDR-669) Unable to run buildr with cucumber in the Gemfile
Date Mon, 10 Jun 2013 01:54:20 GMT

     [ https://issues.apache.org/jira/browse/BUILDR-669?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Peter Donald closed BUILDR-669.
-------------------------------

       Resolution: Cannot Reproduce
    Fix Version/s: 1.4.13
         Assignee: Peter Donald
    
> Unable to run buildr with cucumber in the Gemfile
> -------------------------------------------------
>
>                 Key: BUILDR-669
>                 URL: https://issues.apache.org/jira/browse/BUILDR-669
>             Project: Buildr
>          Issue Type: Bug
>          Components: Dependency management
>    Affects Versions: 1.4.11
>         Environment: Fedora 18
>            Reporter: Jacek Furmankiewicz
>            Assignee: Peter Donald
>            Priority: Blocker
>             Fix For: 1.4.13
>
>
> I have this test project which I was considering moving from Gradle to Buildr:
> https://github.com/jacek99/dropwizard-spring-di-security-onejar-example
> once you do bundle install and then gem install buildr, buildr fails to run due to dependencies
on builder:
> buildr
> /home/jacekf/.gem/ruby/1.9.1/gems/bundler-1.3.5/lib/bundler/runtime.rb:33:in `block in
setup': You have already activated builder 3.1.3, but your Gemfile requires builder 3.2.0.
Using bundle exec may solve this. (Gem::LoadError)
> 	from /home/jacekf/.gem/ruby/1.9.1/gems/bundler-1.3.5/lib/bundler/runtime.rb:19:in `setup'
> 	from /home/jacekf/.gem/ruby/1.9.1/gems/bundler-1.3.5/lib/bundler.rb:120:in `setup'
> 	from /home/jacekf/.gem/ruby/1.9.1/gems/bundler-1.3.5/lib/bundler/setup.rb:7:in `<top
(required)>'
> 	from /usr/local/share/ruby/site_ruby/rubygems/core_ext/kernel_require.rb:45:in `require'
> 	from /usr/local/share/ruby/site_ruby/rubygems/core_ext/kernel_require.rb:45:in `require'
> 	from /home/jacekf/.gem/ruby/1.9.1/gems/buildr-1.4.12/bin/buildr:18:in `<top (required)>'
> 	from /home/jacekf/bin/buildr:23:in `load'
> I am guessing that the dependency on builder needs to be updated accordingly.
> As a result I am not able to run buildr at all.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message