buildr-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Peter Donald (JIRA)" <>
Subject [jira] [Closed] (BUILDR-636) Do not set hard version numbers for gem dependencies unless absolutely necessary
Date Tue, 15 Jan 2013 03:02:12 GMT


Peter Donald closed BUILDR-636.

       Resolution: Won't Fix
    Fix Version/s:     (was: 1.5)
         Assignee: Peter Donald

With the advent of bundler as a mechanism for managing all the dependencies, I think it is
much less of an issue these days to use explicit dependencies. 

It is still difficult to get a set of libraries that are consistent and work across all different
platforms, so I don't see our strategy for maintaining fixed versions changing in the near

Thus I will close this issue until we can remove some of the more flakey libraries or the
ruby libraries stabilize somewhat.
> Do not set hard version numbers for gem dependencies unless absolutely necessary
> --------------------------------------------------------------------------------
>                 Key: BUILDR-636
>                 URL:
>             Project: Buildr
>          Issue Type: Dependency upgrade
>    Affects Versions: 1.4.6, 1.4.7
>            Reporter: Russell Teabeault
>            Assignee: Peter Donald
>             Fix For: 1.4.10
> I am finding more and more that buildr's gem dependencies are causing conflicts with
my own project's gem requirements.  This is typically because the version in the gemspec is
set to a specific version instead of a minimum version.
> For example in buildr.gemspec,
> spec.add_dependency 'rake', '0.8.7'
> probably should be
> spec.add_dependency 'rake', '>= 0.8.7'
> unless there is a good reason that it only works with rake 0.8.7.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:

View raw message