buildr-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Peter Donald (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (BUILDR-636) Do not set hard version numbers for gem dependencies unless absolutely necessary
Date Sat, 06 Oct 2012 23:49:13 GMT

     [ https://issues.apache.org/jira/browse/BUILDR-636?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Peter Donald updated BUILDR-636:
--------------------------------

    Fix Version/s: 1.5
    
> Do not set hard version numbers for gem dependencies unless absolutely necessary
> --------------------------------------------------------------------------------
>
>                 Key: BUILDR-636
>                 URL: https://issues.apache.org/jira/browse/BUILDR-636
>             Project: Buildr
>          Issue Type: Dependency upgrade
>    Affects Versions: 1.4.6, 1.4.7
>            Reporter: Russell Teabeault
>             Fix For: 1.5
>
>
> I am finding more and more that buildr's gem dependencies are causing conflicts with
my own project's gem requirements.  This is typically because the version in the gemspec is
set to a specific version instead of a minimum version.
> For example in buildr.gemspec,
> spec.add_dependency 'rake', '0.8.7'
> probably should be
> spec.add_dependency 'rake', '>= 0.8.7'
> unless there is a good reason that it only works with rake 0.8.7.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message