buildr-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From dona...@apache.org
Subject svn commit: r1402712 - /buildr/trunk/rakelib/stage.rake
Date Fri, 26 Oct 2012 23:26:00 GMT
Author: donaldp
Date: Fri Oct 26 23:25:59 2012
New Revision: 1402712

URL: http://svn.apache.org/viewvc?rev=1402712&view=rev
Log:
Remove the call to scrape project in RubyForge gem as it no longer seems to work

Modified:
    buildr/trunk/rakelib/stage.rake

Modified: buildr/trunk/rakelib/stage.rake
URL: http://svn.apache.org/viewvc/buildr/trunk/rakelib/stage.rake?rev=1402712&r1=1402711&r2=1402712&view=diff
==============================================================================
--- buildr/trunk/rakelib/stage.rake (original)
+++ buildr/trunk/rakelib/stage.rake Fri Oct 26 23:25:59 2012
@@ -21,7 +21,7 @@ gpg_cmd = 'gpg2'
 
 task 'prepare' do |task, args|
   gpg_arg = args.gpg || ENV['gpg']
-  
+
   # Make sure we're doing a release from checked code.
   lambda do
     puts 'Checking there are no local changes ... '
@@ -61,14 +61,6 @@ task 'prepare' do |task, args|
     puts '[X] We have prince available'
   end.call
 
-  # Need RubyForge to upload new release files.
-  lambda do
-    puts '[!] Make sure you have admin privileges to make a release on RubyForge'
-    rubyforge = RubyForge.new.configure
-    rubyforge.login
-    rubyforge.scrape_project(spec.name)
-  end.call
-
   raise "Can not run stage process under jruby" if RUBY_PLATFORM[/java/]
   raise "Can not run staging process under older rubies" unless RUBY_VERSION >= '1.9'
 end



Mime
View raw message