buildr-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Peter Donald (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (BUILDR-612) Buildr to support newer versions of Testng
Date Sat, 06 Oct 2012 23:49:14 GMT

     [ https://issues.apache.org/jira/browse/BUILDR-612?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Peter Donald updated BUILDR-612:
--------------------------------

    Fix Version/s: 1.5
    
> Buildr to support newer versions of Testng
> ------------------------------------------
>
>                 Key: BUILDR-612
>                 URL: https://issues.apache.org/jira/browse/BUILDR-612
>             Project: Buildr
>          Issue Type: Dependency upgrade
>          Components: Test frameworks
>    Affects Versions: 1.4.6
>            Reporter: Tilman Keskinöz
>            Priority: Minor
>             Fix For: 1.5
>
>
> Currently defaults to TestNG 5.10.
> Latest version of TestNG is 6.10
> Problem Description:
> buildr supports overriding the testNG version used via build.yaml, but the Artifact format
has changed from "org.testng:testng:jar:jdk15:#{version}" to "org.testng:testng:jar:#{version}"
in test.rb line 311
> I extended the TestNG class to change the artifact, which allowed me to update to 5.12.1,
but after 5.13 the commandline arguments of testng changed. 
> I am still in the process to find out how to modify the TestNG class.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message