buildr-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antoine Toulme (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (BUILDR-628) Crash on first Running Build
Date Sun, 11 Mar 2012 18:16:59 GMT

    [ https://issues.apache.org/jira/browse/BUILDR-628?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13227126#comment-13227126
] 

Antoine Toulme commented on BUILDR-628:
---------------------------------------

The problem is ibiblio, we will switch to the canonical maven repo (http://repo1.maven.org)
which will do fine. We should also upgrade Ant for good measure.
                
> Crash on first Running Build
> ----------------------------
>
>                 Key: BUILDR-628
>                 URL: https://issues.apache.org/jira/browse/BUILDR-628
>             Project: Buildr
>          Issue Type: Bug
>          Components: Core features
>    Affects Versions: 1.4.5, 1.4.6
>         Environment: Duplicated in Mac OS/X and Linux
>            Reporter: Ed Smiley
>
> I have a fully replicable method of installing Buildr, and choosing the latest, I get
1.46.
> However if I run my existing buildfile against a nonzero number of source files it tries
to download ant libraries from ibiblio and fails.
> I then just ran buildr in an empty directory and created the default project generated
with 1.46 to see if I could reproduce the error.
> If I run Buildr it makes a project fine.
> As soon as I drop Java files in src/main/java/ so that it has something to compile I
get the error again, so this is something very fundamental.
> The error is:
> RuntimeError : Failed to download org.apache.ant:ant:jar:1.8.0, tried the following repositories:
> http://www.ibiblio.org/maven2//
> The .m2 subdirectory is not created.
> I have been able to duplicate this on both Mac OS/X and Linux.
> I have also been able to find other users with the same problem, here:
> http://stackoverflow.com/questions/9253099/buildr-build-aborted-unable-to-download-from-repo
> Workaround:
> The traditional Maven repo on Ibiblio appears to be missing some or all of the needed
Buildr components.
> Adding a mirror URL resolves the problem:
> Include the mirrors in the buildfile, to get full reliability
> # Specify Maven 2.0 remote repositories
> repositories.remote << "http://www.ibiblio.org/maven2"
> repositories.remote << 'http://mirrors.ibiblio.org/pub/mirrors/maven2/'
> This resolves the one-time Maven download problem.
> Proposed resolution:
> 1. For new users, construct the auto-generated project files with the two lines.
> 2. For backward compatibility, look for the old setup, and catch the error with a meaningful
message like
> "Older buildfile detected, we recommend you add line repositories.remote << 'http://mirrors.ibiblio.org/pub/mirrors/maven2/'.
Would you like us to do it for you? Y/n".
> If the user selects Y, insert the line.  If they choose n, tell the user, "you will need
to add a custom repository to install Buildr libraries"

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message