buildr-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Russell Teabeault (Created) (JIRA)" <j...@apache.org>
Subject [jira] [Created] (BUILDR-614) Buildr development - Using rvm, bundler and OSX installs the wrong rjb
Date Mon, 14 Nov 2011 23:07:51 GMT
Buildr development - Using rvm, bundler and OSX installs the wrong rjb
----------------------------------------------------------------------

                 Key: BUILDR-614
                 URL: https://issues.apache.org/jira/browse/BUILDR-614
             Project: Buildr
          Issue Type: Bug
         Environment: rvm 1.6.32
bundler version 1.0.21
ruby 1.8.7-p352
OSX 10.6.8
            Reporter: Russell Teabeault


The Gemfile for buildr specifies rjb as a dependency.  However, when running on OSX and using
rvm, the rjb that gets installed is the version compiled against the OSX system ruby instead
of the rvm ruby.  This can be fixed by adding the following to the Gemfile:

  if `uname`.strip == 'Darwin' and ENV["rvm_ruby_string"] != 'system'
    Gem.platforms = [Gem::Platform::RUBY]
  end

I think in the end this is probably an rjb problem but adding this to the Gemfile would be
helpful for buildr developers woring with rvm and OSX.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message