buildr-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Peter Donald (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (BUILDR-310) Using net-ssh/net-scp in buildr scripts doesnt work
Date Wed, 22 Jun 2011 10:12:48 GMT

     [ https://issues.apache.org/jira/browse/BUILDR-310?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Peter Donald closed BUILDR-310.
-------------------------------


> Using net-ssh/net-scp in buildr scripts doesnt work
> ---------------------------------------------------
>
>                 Key: BUILDR-310
>                 URL: https://issues.apache.org/jira/browse/BUILDR-310
>             Project: Buildr
>          Issue Type: Bug
>          Components: JRuby
>    Affects Versions: 1.3.4
>         Environment: Linux 2.6.28-15-generic #49-Ubuntu SMP i686 GNU/Linux
>            Reporter: Thilko Richter
>            Priority: Critical
>             Fix For: 1.3.5
>
>
> Using net-ssh or net-scp causing the following error:
> Buildr aborted!
> padding error, need 249417156 block 16
> /home/thilko/.gem/jruby/1.8/gems/net-ssh-2.0.11/lib/net/ssh/transport/packet_stream.rb:195:in
`poll_next_packet'
> /home/thilko/.gem/jruby/1.8/gems/net-ssh-2.0.11/lib/net/ssh/transport/packet_stream.rb:85:in
`next_packet'
> /home/thilko/.gem/jruby/1.8/gems/net-ssh-2.0.11/lib/net/ssh/transport/packet_stream.rb:84:in
`loop'
> /home/thilko/.gem/jruby/1.8/gems/net-ssh-2.0.11/lib/net/ssh/transport/packet_stream.rb:84:in
`next_packet'
> /home/thilko/.gem/jruby/1.8/gems/net-ssh-2.0.11/lib/net/ssh/transport/session.rb:169:in
`poll_message'
> /home/thilko/.gem/jruby/1.8/gems/net-ssh-2.0.11/lib/net/ssh/transport/session.rb:164:in
`loop'
> /home/thilko/.gem/jruby/1.8/gems/net-ssh-2.0.11/lib/net/ssh/transport/session.rb:164:in
`poll_message'
> /home/thilko/.gem/jruby/1.8/gems/net-ssh-2.0.11/lib/net/ssh/transport/session.rb:149:in
`next_message'
> /home/thilko/.gem/jruby/1.8/gems/net-ssh-2.0.11/lib/net/ssh/authentication/session.rb:82:in
`next_message'
> /home/thilko/.gem/jruby/1.8/gems/net-ssh-2.0.11/lib/net/ssh/authentication/session.rb:81:in
`loop'
> /home/thilko/.gem/jruby/1.8/gems/net-ssh-2.0.11/lib/net/ssh/authentication/session.rb:81:in
`next_message'
> /home/thilko/.gem/jruby/1.8/gems/net-ssh-2.0.11/lib/net/ssh/authentication/methods/publickey.rb:53:in
`authenticate_with'
> /home/thilko/.gem/jruby/1.8/gems/net-ssh-2.0.11/lib/net/ssh/authentication/methods/publickey.rb:20:in
`authenticate'
> /home/thilko/.gem/jruby/1.8/gems/net-ssh-2.0.11/lib/net/ssh/authentication/key_manager.rb:97:in
`each_identity'
> /home/thilko/.gem/jruby/1.8/gems/net-ssh-2.0.11/lib/net/ssh/authentication/key_manager.rb:95:in
`each'
> /home/thilko/.gem/jruby/1.8/gems/net-ssh-2.0.11/lib/net/ssh/authentication/key_manager.rb:95:in
`each_identity'
> /home/thilko/.gem/jruby/1.8/gems/net-ssh-2.0.11/lib/net/ssh/authentication/methods/publickey.rb:19:in
`authenticate'
> /home/thilko/.gem/jruby/1.8/gems/net-ssh-2.0.11/lib/net/ssh/authentication/session.rb:68:in
`authenticate'
> /home/thilko/.gem/jruby/1.8/gems/net-ssh-2.0.11/lib/net/ssh/authentication/session.rb:61:in
`each'
> /home/thilko/.gem/jruby/1.8/gems/net-ssh-2.0.11/lib/net/ssh/authentication/session.rb:61:in
`authenticate'
> /home/thilko/.gem/jruby/1.8/gems/net-ssh-2.0.11/lib/net/ssh.rb:183:in `start'
> /home/thilko/.gem/jruby/1.8/gems/net-scp-1.0.2/lib/net/scp.rb:196:in `start'
> /home/thilko/Aptana Studio Workspace/chief/../Ivy/buildr/lib/blau_deploy.rb:23:in `blau_deploy'
> /home/thilko/Aptana Studio Workspace/chief/../Ivy/buildr/lib/blau_deploy.rb:17:in `after_define'
> /home/thilko/.gem/jruby/1.8/gems/rake-0.8.4/lib/rake.rb:617:in `call'
> /home/thilko/.gem/jruby/1.8/gems/rake-0.8.4/lib/rake.rb:617:in `execute'
> /home/thilko/.gem/jruby/1.8/gems/rake-0.8.4/lib/rake.rb:612:in `each'
> After some research we found the following issue: http://jira.codehaus.org/browse/JRUBY-3385
which indicates that the problem has something to do with the required version of the jruby-openssl
- which is 0.3 for 1.3.4. We changed the version to 0.5.2 and everything work fine.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message