buildr-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Boisvert (JIRA)" <j...@apache.org>
Subject [jira] Updated: (BUILDR-546) Support for Rubyzip 0.9.4
Date Tue, 23 Nov 2010 05:51:17 GMT

     [ https://issues.apache.org/jira/browse/BUILDR-546?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Alex Boisvert updated BUILDR-546:
---------------------------------

        Fix Version/s:     (was: 1.4.3)
                       1.4.5
    Affects Version/s:     (was: 1.4.3)
                       1.4.4

> Support for Rubyzip 0.9.4
> -------------------------
>
>                 Key: BUILDR-546
>                 URL: https://issues.apache.org/jira/browse/BUILDR-546
>             Project: Buildr
>          Issue Type: Improvement
>          Components: Packaging
>    Affects Versions: 1.4.4
>            Reporter: Michael Guymon
>             Fix For: 1.4.5
>
>         Attachments: rubyzip_0.9.4_support.patch
>
>
> To support rubyzip 0.9.4, an override is needed to Zip::ZipEntry#write_c_dir_entry to
fix comments length error.
> This and other monkey patching to Zip::ZipEntry make other gems break (such as warbler
1.2.1) if buildr uses autoload. While the monkey patches exist, rubyzip will have to be required
instead.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message