buildr-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Boisvert (JIRA)" <j...@apache.org>
Subject [jira] Commented: (BUILDR-548) RSpec 2.x broke test.using :rspec
Date Sun, 14 Nov 2010 17:49:13 GMT

    [ https://issues.apache.org/jira/browse/BUILDR-548?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12931847#action_12931847
] 

Alex Boisvert commented on BUILDR-548:
--------------------------------------

I've been working on this and have "test.using :rspec" working however "test.using :jtestr"
breaks since JtestR doesn't support RSpec 2.  I've contacted Ola Bini about this... here's
the thread http://markmail.org/thread/elirkj5i3b6kv6so

One solution may be to stick with JtestR 0.6 and RSpec 1 and maintain two separate RSpec reporters.

> RSpec 2.x broke test.using :rspec
> ---------------------------------
>
>                 Key: BUILDR-548
>                 URL: https://issues.apache.org/jira/browse/BUILDR-548
>             Project: Buildr
>          Issue Type: Bug
>          Components: Test frameworks
>    Affects Versions: 1.4.3
>            Reporter: Peter Donald
>            Assignee: Alex Boisvert
>            Priority: Blocker
>             Fix For: 1.4.4
>
>
> It looks like the upgrade to rspec 2 broke "test.using :rspec". The runner_config in
lib/buildr/java/bdd.rb:241 needs to be updated so something like
>   def runner_config
>       runner = super
>       runner.gems.update 'rspec' => '>= 2.0.1'
>       runner.requires.unshift 'rspec'
>       runner
>     end
> However the API has changed between 2.x and 1.x of rspec so the runner_content method
immediately following will not work.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message