buildr-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Peter Donald (JIRA)" <j...@apache.org>
Subject [jira] Updated: (BUILDR-531) Improve error message when the build requires a gem that can not be found in local or remote gem repositories
Date Sun, 10 Oct 2010 08:03:33 GMT

     [ https://issues.apache.org/jira/browse/BUILDR-531?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Peter Donald updated BUILDR-531:
--------------------------------

    Attachment: ImproveErrorMessageWhenMissingGemRequiredForBuild.diff

> Improve error message when the build requires a gem that can not be found in local or
remote gem repositories
> -------------------------------------------------------------------------------------------------------------
>
>                 Key: BUILDR-531
>                 URL: https://issues.apache.org/jira/browse/BUILDR-531
>             Project: Buildr
>          Issue Type: Improvement
>    Affects Versions: 1.4.2
>            Reporter: Peter Donald
>             Fix For: 1.4.3
>
>         Attachments: ImproveErrorMessageWhenMissingGemRequiredForBuild.diff
>
>
> The error message when a gem required for the build was unable to located was not always
useful. It was "Build requires the gems , which cannot be found in local or remote repository."
(i.e. no gems listed). The attached patch adds the gem name and requirements to the message.

> It also fixed a CI test failure on jruby+windows ... unsure how the test ever passed
on other platforms.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message