buildr-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antoine Toulme (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (BUILDR-528) Stop using deprecated method Gem::Dependency.version_requirements correctly
Date Tue, 12 Oct 2010 13:49:32 GMT

     [ https://issues.apache.org/jira/browse/BUILDR-528?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Antoine Toulme resolved BUILDR-528.
-----------------------------------

    Resolution: Fixed

Let me guess, that would be me...

06:41:57~/w/buildr>svn ci CHANGELOG rakelib/setup.rake -m "fix for BUILDR-528 Stop using
deprecated method Gem::Dependency.version_requirements correctly"
Sending        CHANGELOG
Sending        rakelib/setup.rake
Transmitting file data ..
Committed revision 1021773.

> Stop using deprecated method Gem::Dependency.version_requirements correctly
> ---------------------------------------------------------------------------
>
>                 Key: BUILDR-528
>                 URL: https://issues.apache.org/jira/browse/BUILDR-528
>             Project: Buildr
>          Issue Type: Improvement
>    Affects Versions: 1.4.2
>            Reporter: Peter Donald
>             Fix For: 1.4.3
>
>         Attachments: StopUsingDeprecatedDependencyMethods.diff
>
>
> It looks like someone attempted to stop the setup rake task from using deprecated Gem::Dependency.version_requirements
but got the guard wrong. The attached patch fixes this.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message