buildr-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shane Witbeck (JIRA)" <j...@apache.org>
Subject [jira] Created: (BUILDR-430) `ffi_libraries': no library specif ied (LoadError)
Date Tue, 27 Apr 2010 21:55:31 GMT
`ffi_libraries': no library specif ied (LoadError)
--------------------------------------------------

                 Key: BUILDR-430
                 URL: https://issues.apache.org/jira/browse/BUILDR-430
             Project: Buildr
          Issue Type: Bug
    Affects Versions: 1.4
         Environment: Windows XP, JRuby 1.5RC1, Buildr 1.4RC3
            Reporter: Shane Witbeck


Getting the following error:

C:\p4\spgp4\spg\beaver>jruby -S buildr -v --trace
c:/jruby-1.5.0.RC1/lib/ruby/site_ruby/shared/ffi/library.rb:46:in `ffi_libraries': no library
specif
ied (LoadError)
        from c:/jruby-1.5.0.RC1/lib/ruby/site_ruby/shared/ffi/library.rb:96:in `attach_function'
        from c:/jruby-1.5.0.RC1/lib/ruby/gems/1.8/gems/buildr-1.3.5-java/lib/buildr/core/util.rb:410

        from c:/jruby-1.5.0.RC1/lib/ruby/gems/1.8/gems/buildr-1.3.5-java/lib/buildr/core/util.rb:31:
in `require'
        from c:/jruby-1.5.0.RC1/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
        from c:/jruby-1.5.0.RC1/lib/ruby/gems/1.8/gems/buildr-1.3.5-java/lib/buildr/core/common.rb:1
8
        from c:/jruby-1.5.0.RC1/lib/ruby/gems/1.8/gems/buildr-1.3.5-java/lib/buildr/core/common.rb:3
1:in `require'
        from c:/jruby-1.5.0.RC1/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
        from c:/jruby-1.5.0.RC1/lib/ruby/gems/1.8/gems/buildr-1.3.5-java/lib/buildr/core.rb:22
        from c:/jruby-1.5.0.RC1/lib/ruby/gems/1.8/gems/buildr-1.3.5-java/lib/buildr/core.rb:31:in
`r
equire'
        from c:/jruby-1.5.0.RC1/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
        from c:/jruby-1.5.0.RC1/lib/ruby/gems/1.8/gems/buildr-1.3.5-java/lib/buildr.rb:20
        from c:/jruby-1.5.0.RC1/lib/ruby/gems/1.8/gems/buildr-1.3.5-java/lib/buildr.rb:31:in
`requir
e'
        from c:/jruby-1.5.0.RC1/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
        from C:/jruby-1.5.0.RC1/lib/ruby/gems/1.8/gems/buildr-1.3.5-java/bin/buildr:18
        from C:/jruby-1.5.0.RC1/lib/ruby/gems/1.8/gems/buildr-1.3.5-java/bin/buildr:19:in
`load'
        from c:/jruby-1.5.0.RC1/bin/buildr:19

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message