buildr-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Boisvert (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (BUILDR-233) can't specify version in artifact namespace
Date Sun, 28 Feb 2010 17:47:05 GMT

     [ https://issues.apache.org/jira/browse/BUILDR-233?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Alex Boisvert resolved BUILDR-233.
----------------------------------

       Resolution: Fixed
    Fix Version/s: 1.4

Appears to work with the current code.  Here's the spec I added:

  it 'should handle version string directly' do
    foo = artifact_ns do |ns|
      ns.bar = 'a:b:c:1.0'
    end
    foo.bar = '2.0'
    foo.bar.version.should == '2.0'
  end


> can't specify version in artifact namespace 
> --------------------------------------------
>
>                 Key: BUILDR-233
>                 URL: https://issues.apache.org/jira/browse/BUILDR-233
>             Project: Buildr
>          Issue Type: Bug
>    Affects Versions: 1.3.2
>            Reporter: Ittay Dror
>            Assignee: Alex Boisvert
>             Fix For: 1.4
>
>
> define 'foo' do
>   artifact_ns do |ns|
>     ns.bar = 'a:b:jar:1.0'
>     ns.bar = '2.0'
>   end
>   compile.with :bar
> end
>  > buildr
> (in /tmp, development)
> Buildr aborted!
> Missing group identifier for {:version=>"2.0"}

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message