buildr-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Boisvert (JIRA)" <j...@apache.org>
Subject [jira] Issue Comment Edited: (BUILDR-233) can't specify version in artifact namespace
Date Sun, 28 Feb 2010 16:41:05 GMT

    [ https://issues.apache.org/jira/browse/BUILDR-233?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12839443#action_12839443
] 

Alex Boisvert edited comment on BUILDR-233 at 2/28/10 4:40 PM:
---------------------------------------------------------------

I'm reopening for investigation.  I think ns.bar = "2.0" needs to be supported for defining
version-only requirements via build.yaml.

      was (Author: boisvert):
    I'm reopening for investigation.  I think artifact_ns.foo = "2.0" needs to be supported
for defining version-only requirements via build.yaml.
  
> can't specify version in artifact namespace 
> --------------------------------------------
>
>                 Key: BUILDR-233
>                 URL: https://issues.apache.org/jira/browse/BUILDR-233
>             Project: Buildr
>          Issue Type: Bug
>    Affects Versions: 1.3.2
>            Reporter: Ittay Dror
>            Assignee: Alex Boisvert
>
> define 'foo' do
>   artifact_ns do |ns|
>     ns.bar = 'a:b:jar:1.0'
>     ns.bar = '2.0'
>   end
>   compile.with :bar
> end
>  > buildr
> (in /tmp, development)
> Buildr aborted!
> Missing group identifier for {:version=>"2.0"}

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message