buildr-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From as...@apache.org
Subject svn commit: r755313 - in /buildr/trunk/doc: getting_started.textile scripts/install-linux.sh scripts/install-osx.sh
Date Tue, 17 Mar 2009 16:37:24 GMT
Author: assaf
Date: Tue Mar 17 16:37:24 2009
New Revision: 755313

URL: http://svn.apache.org/viewvc?rev=755313&view=rev
Log:
Updated OS X/Linux install scripts to use RubyGems 1.3.1

Modified:
    buildr/trunk/doc/getting_started.textile
    buildr/trunk/doc/scripts/install-linux.sh
    buildr/trunk/doc/scripts/install-osx.sh

Modified: buildr/trunk/doc/getting_started.textile
URL: http://svn.apache.org/viewvc/buildr/trunk/doc/getting_started.textile?rev=755313&r1=755312&r2=755313&view=diff
==============================================================================
--- buildr/trunk/doc/getting_started.textile (original)
+++ buildr/trunk/doc/getting_started.textile Tue Mar 17 16:37:24 2009
@@ -37,9 +37,9 @@
 
 <notextile>
 {% highlight sh %}
-$ wget http://rubyforge.org/frs/download.php/38646/rubygems-1.2.0.tgz 
-$ tar xzf rubygems-1.2.0.tgz
-$ cd rubygems-1.2.0
+$ wget http://rubyforge.org/frs/download.php/45905/rubygems-1.3.1.tgz
+$ tar xzf rubygems-1.3.1.tgz
+$ cd rubygems-1.3.1
 $ sudo ruby setup.rb
 $ sudo ln -s /usr/bin/gem1.8 /usr/bin/gem
 {% endhighlight %}

Modified: buildr/trunk/doc/scripts/install-linux.sh
URL: http://svn.apache.org/viewvc/buildr/trunk/doc/scripts/install-linux.sh?rev=755313&r1=755312&r2=755313&view=diff
==============================================================================
--- buildr/trunk/doc/scripts/install-linux.sh (original)
+++ buildr/trunk/doc/scripts/install-linux.sh Tue Mar 17 16:37:24 2009
@@ -26,12 +26,12 @@
     sudo apt-get install ruby-full ruby1.8-dev libopenssl-ruby build-essential 
     # RubyGems broken on Ubunutu, installing directly from source.
     echo "Installing RubyGems from RubyForge"
-    wget http://rubyforge.org/frs/download.php/38646/rubygems-1.2.0.tgz 
-    tar xzf rubygems-1.2.0.tgz
-    cd rubygems-1.2.0
+    wget http://rubyforge.org/frs/download.php/45905/rubygems-1.3.1.tgz
+    tar xzf rubygems-1.3.1.tgz
+    cd rubygems-1.3.1
     sudo ruby setup.rb
     cd ..
-    rm -rf rubygems-1.2.0
+    rm -rf rubygems-1.3.1
     # ruby is same as ruby1.8, we need gem that is same as gem1.8
     sudo ln -s /usr/bin/gem1.8 /usr/bin/gem
   else
@@ -46,8 +46,8 @@
   exit 1
 fi
 
-if [ $(gem --version) \< '1.0.1' ] ; then
-  echo "Upgrading to RubyGems 1.0.1"
+if [ $(gem --version) \< '1.3.1' ] ; then
+  echo "Upgrading to latest version of RubyGems"
   sudo gem update --system
   echo
 fi

Modified: buildr/trunk/doc/scripts/install-osx.sh
URL: http://svn.apache.org/viewvc/buildr/trunk/doc/scripts/install-osx.sh?rev=755313&r1=755312&r2=755313&view=diff
==============================================================================
--- buildr/trunk/doc/scripts/install-osx.sh (original)
+++ buildr/trunk/doc/scripts/install-osx.sh Tue Mar 17 16:37:24 2009
@@ -34,8 +34,8 @@
   export JAVA_HOME=/Library/Java/Home
 fi
 
-if [ $(gem --version) \< '1.0.1' ] ; then
-  echo "Upgrading to RubyGems 1.0.1"
+if [ $(gem --version) \< '1.3.1' ] ; then
+  echo "Upgrading to latest version of RubyGems"
   sudo gem update --system
   echo
 fi



Mime
View raw message