buildr-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kelly Harward (JIRA)" <j...@apache.org>
Subject [jira] Updated: (BUILDR-137) JRuby 1.1.3 and Buildr 1.3.2 don't appear to work
Date Fri, 22 Aug 2008 15:50:46 GMT

     [ https://issues.apache.org/jira/browse/BUILDR-137?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Kelly Harward updated BUILDR-137:
---------------------------------

        Fix Version/s:     (was: 1.3.2)
          Description: 
This occurs after a fresh install...

C:\temp>buildr --version
C:/Program Files/Java/jruby-1.1.3/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require': no such file to load -- dl/import (LoadError)
        from C:/Program Files/Java/jruby-1.1.3/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'
        from C:/Program Files/Java/jruby-1.1.3/lib/ruby/gems/1.8/gems/net-ssh-2.0.3/lib/net/ssh/authentication/pageant.rb:1
        from C:/Program Files/Java/jruby-1.1.3/lib/ruby/gems/1.8/gems/net-ssh-2.0.3/lib/net/ssh/authentication/pageant.rb:27:in
`require'
        from C:/Program Files/Java/jruby-1.1.3/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'
        from C:/Program Files/Java/jruby-1.1.3/lib/ruby/gems/1.8/gems/net-ssh-2.0.3/lib/net/ssh/authentication/agent.rb:6
        from C:/Program Files/Java/jruby-1.1.3/lib/ruby/gems/1.8/gems/net-ssh-2.0.3/lib/net/ssh/authentication/agent.rb:27:in
`require'
        from C:/Program Files/Java/jruby-1.1.3/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'
        from C:/Program Files/Java/jruby-1.1.3/lib/ruby/gems/1.8/gems/net-ssh-2.0.3/lib/net/ssh/authentication/key_manager.rb:4
         ... 20 levels...
        from C:/Program Files/Java/jruby-1.1.3/lib/ruby/gems/1.8/gems/buildr-1.3.2-java/bin/buildr:19
        from C:/Program Files/Java/jruby-1.1.3/lib/ruby/gems/1.8/gems/buildr-1.3.2-java/bin/buildr:19:in
`load'
        from C:\Program Files\Java\jruby-1.1.3\bin\buildr:19

  was:
This occurs after a fresh install...

C:\Documents and Settings\Shane>jruby -S buildr
C:/jruby-1.1.2/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
: no such file to load -- dl/import (LoadError)
        from C:/jruby-1.1.2/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27
:in `require'
        from C:/jruby-1.1.2/lib/ruby/gems/1.8/gems/net-ssh-2.0.1/lib/net/ssh/aut
hentication/pageant.rb:1:in `C:/jruby-1.1.2/lib/ruby/gems/1.8/gems/net-ssh-2.0.1
/lib/net/ssh/authentication/pageant.rb'
        from C:/jruby-1.1.2/lib/ruby/gems/1.8/gems/net-ssh-2.0.1/lib/net/ssh/aut
hentication/pageant.rb:27:in `require'
        from C:/jruby-1.1.2/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27
:in `require'
        from C:/jruby-1.1.2/lib/ruby/gems/1.8/gems/net-ssh-2.0.1/lib/net/ssh/aut
hentication/agent.rb:6:in `C:/jruby-1.1.2/lib/ruby/gems/1.8/gems/net-ssh-2.0.1/l
ib/net/ssh/authentication/agent.rb'
        from C:/jruby-1.1.2/lib/ruby/gems/1.8/gems/net-ssh-2.0.1/lib/net/ssh/aut
hentication/agent.rb:27:in `require'
        from C:/jruby-1.1.2/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27
:in `require'
        from C:/jruby-1.1.2/lib/ruby/gems/1.8/gems/net-ssh-2.0.1/lib/net/ssh/aut
hentication/key_manager.rb:4:in `C:/jruby-1.1.2/lib/ruby/gems/1.8/gems/net-ssh-2
.0.1/lib/net/ssh/authentication/key_manager.rb'
         ... 11 levels...
        from C:/jruby-1.1.2/lib/ruby/gems/1.8/gems/buildr-1.3.1.1-java/bin/build
r:19:in `C:/jruby-1.1.2/lib/ruby/gems/1.8/gems/buildr-1.3.1.1-java/bin/buildr'
        from C:/jruby-1.1.2/lib/ruby/gems/1.8/gems/buildr-1.3.1.1-java/bin/build
r:19:in `load'
        from C:/jruby-1.1.2/bin/buildr:19

          Environment: Windows XP, Buildr 1.3.2 (via gem install), JRuby 1.1.3, JDK 1.6.0_02
 (was: Windows XP, Buildr 1.3.1.1 (via gem install), JDK 1.6.0_06)
    Affects Version/s:     (was: 1.3.1)
                       1.3.2

> JRuby 1.1.3 and Buildr 1.3.2 don't appear to work
> -------------------------------------------------
>
>                 Key: BUILDR-137
>                 URL: https://issues.apache.org/jira/browse/BUILDR-137
>             Project: Buildr
>          Issue Type: Bug
>          Components: JRuby
>    Affects Versions: 1.3.2
>         Environment: Windows XP, Buildr 1.3.2 (via gem install), JRuby 1.1.3, JDK 1.6.0_02
>            Reporter: Kelly Harward
>            Priority: Blocker
>
> This occurs after a fresh install...
> C:\temp>buildr --version
> C:/Program Files/Java/jruby-1.1.3/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require': no such file to load -- dl/import (LoadError)
>         from C:/Program Files/Java/jruby-1.1.3/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'
>         from C:/Program Files/Java/jruby-1.1.3/lib/ruby/gems/1.8/gems/net-ssh-2.0.3/lib/net/ssh/authentication/pageant.rb:1
>         from C:/Program Files/Java/jruby-1.1.3/lib/ruby/gems/1.8/gems/net-ssh-2.0.3/lib/net/ssh/authentication/pageant.rb:27:in
`require'
>         from C:/Program Files/Java/jruby-1.1.3/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'
>         from C:/Program Files/Java/jruby-1.1.3/lib/ruby/gems/1.8/gems/net-ssh-2.0.3/lib/net/ssh/authentication/agent.rb:6
>         from C:/Program Files/Java/jruby-1.1.3/lib/ruby/gems/1.8/gems/net-ssh-2.0.3/lib/net/ssh/authentication/agent.rb:27:in
`require'
>         from C:/Program Files/Java/jruby-1.1.3/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'
>         from C:/Program Files/Java/jruby-1.1.3/lib/ruby/gems/1.8/gems/net-ssh-2.0.3/lib/net/ssh/authentication/key_manager.rb:4
>          ... 20 levels...
>         from C:/Program Files/Java/jruby-1.1.3/lib/ruby/gems/1.8/gems/buildr-1.3.2-java/bin/buildr:19
>         from C:/Program Files/Java/jruby-1.1.3/lib/ruby/gems/1.8/gems/buildr-1.3.2-java/bin/buildr:19:in
`load'
>         from C:\Program Files\Java\jruby-1.1.3\bin\buildr:19

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message