buildr-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Assaf Arkin (JIRA)" <j...@apache.org>
Subject [jira] Commented: (BUILDR-137) JRuby 1.1.3 and Buildr 1.3.2 don't appear to work (on Windows)
Date Fri, 22 Aug 2008 23:34:46 GMT

    [ https://issues.apache.org/jira/browse/BUILDR-137?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12624999#action_12624999
] 

Assaf Arkin commented on BUILDR-137:
------------------------------------

The problem is actually with Net::SSH, and it will consistently fail whichever version of
JRuby you use because it incorrectly detects the platform.

Any ideas on how we can get it tested so it doesn't break again?

> JRuby 1.1.3 and Buildr 1.3.2 don't appear to work (on Windows)
> --------------------------------------------------------------
>
>                 Key: BUILDR-137
>                 URL: https://issues.apache.org/jira/browse/BUILDR-137
>             Project: Buildr
>          Issue Type: Bug
>          Components: JRuby
>    Affects Versions: 1.3.2
>         Environment: Windows Vista, Buildr 1.3.2 (via gem install), JRuby 1.1.3, JDK
1.6.0_02
>            Reporter: Kelly Harward
>            Priority: Blocker
>
> This occurs after a fresh install...
> C:\temp>buildr --version
> C:/Program Files/Java/jruby-1.1.3/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require': no such file to load -- dl/import (LoadError)
>         from C:/Program Files/Java/jruby-1.1.3/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'
>         from C:/Program Files/Java/jruby-1.1.3/lib/ruby/gems/1.8/gems/net-ssh-2.0.3/lib/net/ssh/authentication/pageant.rb:1
>         from C:/Program Files/Java/jruby-1.1.3/lib/ruby/gems/1.8/gems/net-ssh-2.0.3/lib/net/ssh/authentication/pageant.rb:27:in
`require'
>         from C:/Program Files/Java/jruby-1.1.3/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'
>         from C:/Program Files/Java/jruby-1.1.3/lib/ruby/gems/1.8/gems/net-ssh-2.0.3/lib/net/ssh/authentication/agent.rb:6
>         from C:/Program Files/Java/jruby-1.1.3/lib/ruby/gems/1.8/gems/net-ssh-2.0.3/lib/net/ssh/authentication/agent.rb:27:in
`require'
>         from C:/Program Files/Java/jruby-1.1.3/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'
>         from C:/Program Files/Java/jruby-1.1.3/lib/ruby/gems/1.8/gems/net-ssh-2.0.3/lib/net/ssh/authentication/key_manager.rb:4
>          ... 20 levels...
>         from C:/Program Files/Java/jruby-1.1.3/lib/ruby/gems/1.8/gems/buildr-1.3.2-java/bin/buildr:19
>         from C:/Program Files/Java/jruby-1.1.3/lib/ruby/gems/1.8/gems/buildr-1.3.2-java/bin/buildr:19:in
`load'
>         from C:\Program Files\Java\jruby-1.1.3\bin\buildr:19

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message