buildr-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From vbo...@apache.org
Subject svn commit: r639893 - in /incubator/buildr/trunk: doc/pages/getting_started.textile doc/scripts/install-jruby.sh lib/java/jruby.rb
Date Fri, 21 Mar 2008 22:23:42 GMT
Author: vborja
Date: Fri Mar 21 15:23:40 2008
New Revision: 639893

URL: http://svn.apache.org/viewvc?rev=639893&view=rev
Log:
Upgrade to JRuby1.1RC3

Modified:
    incubator/buildr/trunk/doc/pages/getting_started.textile
    incubator/buildr/trunk/doc/scripts/install-jruby.sh
    incubator/buildr/trunk/lib/java/jruby.rb

Modified: incubator/buildr/trunk/doc/pages/getting_started.textile
URL: http://svn.apache.org/viewvc/incubator/buildr/trunk/doc/pages/getting_started.textile?rev=639893&r1=639892&r2=639893&view=diff
==============================================================================
--- incubator/buildr/trunk/doc/pages/getting_started.textile (original)
+++ incubator/buildr/trunk/doc/pages/getting_started.textile Fri Mar 21 15:23:40 2008
@@ -135,7 +135,7 @@
 
 h3. JRuby
 
-If you don't already have JRuby 1.1RC2 or later installed, you can download it
+If you don't already have JRuby 1.1RC3 or later installed, you can download it
 from the "JRuby site":http://dist.codehaus.org/jruby/.
 
 After uncompressing JRuby, update your @PATH@ to include both @java@ and @jruby@
@@ -165,7 +165,7 @@
 You can also use this script "to install Buildr on
 JRuby":scripts/install-jruby.sh.  This script will install Buildr or if already
 installed, upgrade to a more recent version.  If necessary, it will also
-install JRuby 1.1RC2 in @/opt/jruby@ and update the @PATH@ variable in
+install JRuby 1.1RC3 in @/opt/jruby@ and update the @PATH@ variable in
 @~/.bash_profile@ or @~/.profile@.
 
 *Important: Running JRuby and Ruby side by side*

Modified: incubator/buildr/trunk/doc/scripts/install-jruby.sh
URL: http://svn.apache.org/viewvc/incubator/buildr/trunk/doc/scripts/install-jruby.sh?rev=639893&r1=639892&r2=639893&view=diff
==============================================================================
--- incubator/buildr/trunk/doc/scripts/install-jruby.sh (original)
+++ incubator/buildr/trunk/doc/scripts/install-jruby.sh Fri Mar 21 15:23:40 2008
@@ -14,7 +14,7 @@
 # License for the specific language governing permissions and limitations under
 # the License.
 if [ -z `which jruby` ] ; then
-  version=1.1RC2
+  version=1.1RC3
   target=/opt/jruby
   echo "Installing JRuby ${version} in ${target}"
   sudo mkdir -p $(dirname ${target})

Modified: incubator/buildr/trunk/lib/java/jruby.rb
URL: http://svn.apache.org/viewvc/incubator/buildr/trunk/lib/java/jruby.rb?rev=639893&r1=639892&r2=639893&view=diff
==============================================================================
--- incubator/buildr/trunk/lib/java/jruby.rb (original)
+++ incubator/buildr/trunk/lib/java/jruby.rb Fri Mar 21 15:23:40 2008
@@ -104,20 +104,3 @@
   end
   
 end
-
-
-# File.fnmatch bug on JRuby1.1RC2. 
-# This issue has been fixed on jruby's trunk, so delete this monkey patch
-# when we upgrade to a new JRuby release.
-# http://jira.codehaus.org/browse/JRUBY-2196
-class File
-  class << self
-    def fnmatch_with_workaround2196(pattern, file, *flags)
-      return true if pattern == '**/*' && flags.include?(FNM_PATHNAME)
-      fnmatch_without_workaround2196(pattern, file, *flags)
-    end
-    
-    alias_method_chain :fnmatch, :workaround2196
-  end
-end
-



Mime
View raw message