buildr-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Victor Hugo Borja (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (BUILDR-4) XMLBeans task should use the same XMLBeans version as defined in the project
Date Wed, 26 Mar 2008 00:15:24 GMT

     [ https://issues.apache.org/jira/browse/BUILDR-4?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Victor Hugo Borja resolved BUILDR-4.
------------------------------------

    Resolution: Fixed

Buildr::XMLBeans now uses ArtifactNamespace(see rdoc), allowing to customize artifact versions
with something like:

{
   require 'buildr/xmlbeans'
   Buildr::XMLBeans::REQUIRES[:xmlbeans] = '2.2.0'
}


> XMLBeans task should use the same XMLBeans version as defined in the project
> ----------------------------------------------------------------------------
>
>                 Key: BUILDR-4
>                 URL: https://issues.apache.org/jira/browse/BUILDR-4
>             Project: Buildr
>          Issue Type: Bug
>          Components: Extensions
>    Affects Versions: 1.2.10
>         Environment: Buildr 1.2.10
>            Reporter: Tammo van Lessen
>            Assignee: Victor Hugo Borja
>             Fix For: 1.3
>
>
> I recently upgraded Buildr and ran into some issues with Ode.
> Buildr compiles generated classes with XMLBeans 2.3 but Ode uses XMLBeans 2.2 which is
not upward compatible.
> You can reproduce this by compiling the recent ode trunk with Buildr 1.2.10 and then
deploying the war into a tomcat.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message