buildr-ci mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Jenkins Server <jenk...@builds.apache.org>
Subject Build failed in Jenkins: Buildr-ci-matrix » 1.6,jruby,ubuntu2 #111
Date Wed, 20 Mar 2013 16:06:31 GMT
See <https://builds.apache.org/job/Buildr-ci-matrix/./BUILD_JVM=1.6,BUILD_RVM=jruby,label=ubuntu2/111/changes>

Changes:

[donaldp] Correctly link to the rdoc

[donaldp] Update the publish task so that it works

------------------------------------------
Started by upstream project "Buildr-ci-matrix" build number 111
originally caused by: 
 Started by an SCM change
Building remotely on ubuntu2 in workspace <https://builds.apache.org/job/Buildr-ci-matrix/./BUILD_JVM=1.6,BUILD_RVM=jruby,label=ubuntu2/ws/>
Updating http://svn.apache.org/repos/asf/buildr/trunk
U         doc/_layouts/default.html
U         rakelib/doc.rake
At revision 1458823
[ubuntu2] $ /usr/bin/env bash /tmp/hudson1845580256652072465.sh
Gemset was not given.
  Usage:
    rvm gemset  <gemsetname>

********************************************************************
*  RVM will install the environment for Buildr development now.
*  By default it will use ruby-1.9.2-p320.
*  To force use an other version of ruby, set BUILDR_RUBY_VERSION.
*  Examples:
*     export BUILDR_RUBY_VERSION=ruby-1.9.2-p320
*     export BUILDR_RUBY_VERSION=jruby-1.6.7
*     export BUILDR_RUBY_VERSION=ruby-1.8.7-p358
********************************************************************
Using /home/hudson/.rvm/gems/jruby-1.7.1 with gemset ubuntu2
Fetching gem metadata from http://rubygems.org/.....
Fetching gem metadata from http://rubygems.org/..
Using rake (0.9.2.2) 
Using Saikuro (1.1.0) 
Using atoulme-Antwrap (0.7.4) 
Using atoulme-Saikuro (1.2.1) 
Using bouncy-castle-java (1.5.0147) 
Using builder (3.1.3) 
Using bundler (1.2.3) 
Using diff-lcs (1.1.3) 
Using highline (1.6.2) 
Using hoe (3.1.0) 
Using jruby-openssl (0.8.6) 
Using json_pure (1.7.5) 
Using minitar (0.5.3) 
Using jruby-pageant (1.1.1) 
Using net-ssh (2.6.0) 
Using net-sftp (2.0.5) 
Using rspec-core (2.11.1) 
Using rspec-expectations (2.11.3) 
Using rspec-mocks (2.11.3) 
Using rspec (2.11.0) 
Using rubyforge (2.0.4) 
Using rubyzip (0.9.9) 
Using xml-simple (1.1.1) 
Using buildr (1.4.12.dev) from source at <https://builds.apache.org/job/Buildr-ci-matrix/./BUILD_JVM=1.6,BUILD_RVM=jruby,label=ubuntu2/ws/>

Using ci_reporter (1.7.2) 
Using ffi (1.4.0) 
Using ffi-locale (1.0.1) 
Using ffi-ncurses (0.4.0) 
Using pygmentize (0.0.3) 
Using saikuro_treemap (0.2.0) 
Your bundle is complete! Use `bundle show [gemname]` to see where a bundled gem is installed.
exec rake clobber ci --trace

rvm 1.16.10 (latest) by Wayne E. Seguin <wayneeseguin@gmail.com>, Michal Papis <mpapis@gmail.com>
[https://rvm.io/]

** Invoke clobber (first_time)
** Invoke clobber_package (first_time)
** Execute clobber_package
rm -r pkg
rm -r pkg
rm -r pkg
rm -r pkg
** Execute clobber
rm -rf _staged
rm -rf _release
rm -rf target
rm -rf _snapshot
rm -f failed
rm -rf _reports
rm -rf _all-in-one
** Invoke ci (first_time)
** Invoke clobber 
** Invoke load_ci_reporter (first_time)
** Execute load_ci_reporter
** Invoke spec (first_time)
** Invoke _reports (first_time)
** Execute _reports
mkdir -p _reports
** Invoke compile (first_time)
** Execute compile
Compiling Java libraries ...
jruby <https://builds.apache.org/job/Buildr-ci-matrix/./BUILD_JVM=1.6,BUILD_RVM=jruby,label=ubuntu2/ws/_jbuildr>
--buildfile buildr.buildfile compile --trace
LoadError: Could not open library 'ncursesw' : ncursesw: cannot open shared object file: No
such file or directory. Could not open library 'libncursesw.so' : libncursesw.so: cannot open
shared object file: No such file or directory. Could not open library 'libncursesw' : libncursesw:
cannot open shared object file: No such file or directory. Could not open library 'ncurses'
: ncurses: cannot open shared object file: No such file or directory. Could not open library
'libncurses.so' : libncurses.so: cannot open shared object file: No such file or directory.
Could not open library 'libcurses' : libcurses: cannot open shared object file: No such file
or directory. Could not open library 'libcurses.so' : libcurses.so: cannot open shared object
file: No such file or directory
           ffi_lib at /home/hudson/.rvm/rubies/jruby-1.7.1/lib/ruby/shared/ffi/library.rb:82
               map at org/jruby/RubyArray.java:2360
           ffi_lib at /home/hudson/.rvm/rubies/jruby-1.7.1/lib/ruby/shared/ffi/library.rb:64
           NCurses at /home/hudson/.rvm/gems/jruby-1.7.1@ubuntu2/gems/ffi-ncurses-0.4.0/lib/ffi-ncurses.rb:64
               FFI at /home/hudson/.rvm/gems/jruby-1.7.1@ubuntu2/gems/ffi-ncurses-0.4.0/lib/ffi-ncurses.rb:38
            (root) at /home/hudson/.rvm/gems/jruby-1.7.1@ubuntu2/gems/ffi-ncurses-0.4.0/lib/ffi-ncurses.rb:37
           require at org/jruby/RubyKernel.java:1027
            (root) at /home/hudson/.rvm/gems/jruby-1.7.1@ubuntu2/gems/highline-1.6.2/lib/highline/system_extensions.rb:1
  SystemExtensions at /home/hudson/.rvm/gems/jruby-1.7.1@ubuntu2/gems/highline-1.6.2/lib/highline/system_extensions.rb:90
          HighLine at /home/hudson/.rvm/gems/jruby-1.7.1@ubuntu2/gems/highline-1.6.2/lib/highline/system_extensions.rb:13
           require at org/jruby/RubyKernel.java:1027
            (root) at /home/hudson/.rvm/gems/jruby-1.7.1@ubuntu2/gems/highline-1.6.2/lib/highline/system_extensions.rb:12
           require at org/jruby/RubyKernel.java:1027
            (root) at /home/hudson/.rvm/gems/jruby-1.7.1@ubuntu2/gems/highline-1.6.2/lib/highline.rb:1
           require at org/jruby/RubyKernel.java:1027
            (root) at /home/hudson/.rvm/gems/jruby-1.7.1@ubuntu2/gems/highline-1.6.2/lib/highline.rb:16
           require at org/jruby/RubyKernel.java:1027
            (root) at <https://builds.apache.org/job/Buildr-ci-matrix/./BUILD_JVM=1.6,BUILD_RVM=jruby,label=ubuntu2/ws/_jbuildr>:34
rake aborted!
Command failed with status (1): [jruby /home/hudson/hudson-slave/workspace/...]
/home/hudson/.rvm/gems/jruby-1.7.1@ubuntu2/gems/rake-0.9.2.2/lib/rake/file_utils.rb:53:in
`create_shell_runner'
org/jruby/RubyProc.java:249:in `call'
/home/hudson/.rvm/gems/jruby-1.7.1@ubuntu2/gems/rake-0.9.2.2/lib/rake/file_utils.rb:45:in
`sh'
/home/hudson/.rvm/gems/jruby-1.7.1@ubuntu2/gems/rake-0.9.2.2/lib/rake/file_utils_ext.rb:43:in
`sh'
<https://builds.apache.org/job/Buildr-ci-matrix/./BUILD_JVM=1.6,BUILD_RVM=jruby,label=ubuntu2/ws/rakelib/package.rake>:28:in
`(root)'
org/jruby/RubyProc.java:249:in `call'
/home/hudson/.rvm/gems/jruby-1.7.1@ubuntu2/gems/rake-0.9.2.2/lib/rake/task.rb:205:in `execute'
org/jruby/RubyArray.java:1612:in `each'
/home/hudson/.rvm/gems/jruby-1.7.1@ubuntu2/gems/rake-0.9.2.2/lib/rake/task.rb:200:in `execute'
/home/hudson/.rvm/gems/jruby-1.7.1@ubuntu2/gems/rake-0.9.2.2/lib/rake/task.rb:158:in `invoke_with_call_chain'
/home/hudson/.rvm/rubies/jruby-1.7.1/lib/ruby/1.9/monitor.rb:211:in `mon_synchronize'
/home/hudson/.rvm/gems/jruby-1.7.1@ubuntu2/gems/rake-0.9.2.2/lib/rake/task.rb:151:in `invoke_with_call_chain'
/home/hudson/.rvm/gems/jruby-1.7.1@ubuntu2/gems/rake-0.9.2.2/lib/rake/task.rb:176:in `invoke_prerequisites'
org/jruby/RubyArray.java:1612:in `each'
/home/hudson/.rvm/gems/jruby-1.7.1@ubuntu2/gems/rake-0.9.2.2/lib/rake/task.rb:174:in `invoke_prerequisites'
/home/hudson/.rvm/gems/jruby-1.7.1@ubuntu2/gems/rake-0.9.2.2/lib/rake/task.rb:157:in `invoke_with_call_chain'
/home/hudson/.rvm/rubies/jruby-1.7.1/lib/ruby/1.9/monitor.rb:211:in `mon_synchronize'
/home/hudson/.rvm/gems/jruby-1.7.1@ubuntu2/gems/rake-0.9.2.2/lib/rake/task.rb:151:in `invoke_with_call_chain'
/home/hudson/.rvm/gems/jruby-1.7.1@ubuntu2/gems/rake-0.9.2.2/lib/rake/task.rb:176:in `invoke_prerequisites'
org/jruby/RubyArray.java:1612:in `each'
/home/hudson/.rvm/gems/jruby-1.7.1@ubuntu2/gems/rake-0.9.2.2/lib/rake/task.rb:174:in `invoke_prerequisites'
/home/hudson/.rvm/gems/jruby-1.7.1@ubuntu2/gems/rake-0.9.2.2/lib/rake/task.rb:157:in `invoke_with_call_chain'
/home/hudson/.rvm/rubies/jruby-1.7.1/lib/ruby/1.9/monitor.rb:211:in `mon_synchronize'
/home/hudson/.rvm/gems/jruby-1.7.1@ubuntu2/gems/rake-0.9.2.2/lib/rake/task.rb:151:in `invoke_with_call_chain'
/home/hudson/.rvm/gems/jruby-1.7.1@ubuntu2/gems/rake-0.9.2.2/lib/rake/task.rb:144:in `invoke'
/home/hudson/.rvm/gems/jruby-1.7.1@ubuntu2/gems/rake-0.9.2.2/lib/rake/application.rb:116:in
`invoke_task'
/home/hudson/.rvm/gems/jruby-1.7.1@ubuntu2/gems/rake-0.9.2.2/lib/rake/application.rb:94:in
`top_level'
org/jruby/RubyArray.java:1612:in `each'
/home/hudson/.rvm/gems/jruby-1.7.1@ubuntu2/gems/rake-0.9.2.2/lib/rake/application.rb:94:in
`top_level'
/home/hudson/.rvm/gems/jruby-1.7.1@ubuntu2/gems/rake-0.9.2.2/lib/rake/application.rb:133:in
`standard_exception_handling'
/home/hudson/.rvm/gems/jruby-1.7.1@ubuntu2/gems/rake-0.9.2.2/lib/rake/application.rb:88:in
`top_level'
/home/hudson/.rvm/gems/jruby-1.7.1@ubuntu2/gems/rake-0.9.2.2/lib/rake/application.rb:66:in
`run'
/home/hudson/.rvm/gems/jruby-1.7.1@ubuntu2/gems/rake-0.9.2.2/lib/rake/application.rb:133:in
`standard_exception_handling'
/home/hudson/.rvm/gems/jruby-1.7.1@ubuntu2/gems/rake-0.9.2.2/lib/rake/application.rb:63:in
`run'
/home/hudson/.rvm/gems/jruby-1.7.1@ubuntu2/gems/rake-0.9.2.2/bin/rake:33:in `(root)'
org/jruby/RubyKernel.java:1046:in `load'
/home/hudson/.rvm/gems/jruby-1.7.1@ubuntu2/bin/rake:1:in `(root)'
org/jruby/RubyKernel.java:1066:in `eval'
/home/hudson/.rvm/gems/jruby-1.7.1@ubuntu2/bin/ruby_noexec_wrapper:14:in `(root)'
Tasks: TOP => ci => spec => compile
Build step 'Execute shell' marked build as failure
Recording test results

Mime
View raw message