buildr-ci mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Jenkins Server <jenk...@builds.apache.org>
Subject Build failed in Jenkins: Buildr-ci-matrix » 1.7,1.9.2,ubuntu #16
Date Sat, 06 Oct 2012 08:28:40 GMT
See <https://builds.apache.org/job/Buildr-ci-matrix/./BUILD_JVM=1.7,BUILD_RVM=1.9.2,label=ubuntu/16/changes>

Changes:

[donaldp] Ensure RVM is on the path

------------------------------------------
Started by upstream project "Buildr-ci-matrix" build number 16
Building remotely on ubuntu1 in workspace <https://builds.apache.org/job/Buildr-ci-matrix/./BUILD_JVM=1.7,BUILD_RVM=1.9.2,label=ubuntu/ws/>
Updating http://svn.apache.org/repos/asf/buildr/trunk
U         ci.sh
At revision 1394960
[ubuntu] $ /usr/bin/env bash /tmp/hudson4101148344192894556.sh
********************************************************************
*  RVM will install the environment for Buildr development now.
*  By default it will use ruby-1.9.2-p320.
*  To force use an other version of ruby, set BUILDR_RUBY_VERSION.
*  Examples:
*     export BUILDR_RUBY_VERSION=ruby-1.9.2-p320
*     export BUILDR_RUBY_VERSION=jruby-1.6.7
*     export BUILDR_RUBY_VERSION=ruby-1.8.7-p358
********************************************************************
ruby-1.9.2-p320 was not found, running 'rvm install ruby-1.9.2-p320'...
No binary rubies available for: ///ruby-1.9.2-p320.
Continuing with compilation. Please read 'rvm mount' to get more information on binary rubies.
Fetching yaml-0.1.4.tar.gz to /home/jenkins/.rvm/archives
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100  460k  100  460k    0     0  1247k      0 --:--:-- --:--:-- --:--:-- 1387k
Extracting yaml-0.1.4.tar.gz to /home/jenkins/.rvm/src
tee: standard output: Broken pipe
tee: write error
Prepare yaml in /home/jenkins/.rvm/src/yaml-0.1.4.
tee: standard output: Broken pipe
tee: write error
Configuring yaml in /home/jenkins/.rvm/src/yaml-0.1.4.
tee: standard output: Broken pipe
tee: write error
Compiling yaml in /home/jenkins/.rvm/src/yaml-0.1.4.
tee: standard output: Broken pipe
tee: write error
Installing yaml to /home/jenkins/.rvm/usr
tee: standard output: Broken pipe
tee: write error
Installing Ruby from source to: /home/jenkins/.rvm/rubies/ruby-1.9.2-p320, this may take a
while depending on your cpu(s)...
ruby-1.9.2-p320 - #downloading ruby-1.9.2-p320, this may take a while depending on your connection...
tee: standard output: Broken pipe
tee: write error
ruby-1.9.2-p320 - #extracting ruby-1.9.2-p320 to /home/jenkins/.rvm/src/ruby-1.9.2-p320
tee: standard output: Broken pipe
tee: write error
ruby-1.9.2-p320 - #extracted to /home/jenkins/.rvm/src/ruby-1.9.2-p320
ruby-1.9.2-p320 - #configuring
tee: standard output: Broken pipe
tee: write error
ruby-1.9.2-p320 - #compiling
tee: standard output: Broken pipe
tee: write error
ruby-1.9.2-p320 - #installing 
tee: standard output: Broken pipe
tee: write error
Removing old Rubygems files...
Installing rubygems-1.8.24 for ruby-1.9.2-p320 ...
tee: standard output: Broken pipe
tee: write error
Installation of rubygems completed successfully.
Saving wrappers to '/home/jenkins/.rvm/bin'.
tee: standard output: Broken pipe
tee: write error
ruby-1.9.2-p320 - #adjusting #shebangs for (gem irb erb ri rdoc testrb rake).
ruby-1.9.2-p320 - #importing default gemsets (/home/jenkins/.rvm/gemsets/)
Install of ruby-1.9.2-p320 - #complete 
RVM is not a function, selecting rubies with 'rvm use ...' will not work.

You need to change your terminal emulator preferences to allow login shell.
Sometimes it is required to use `/bin/bash --login` as the command.
Please visit https://rvm.io/integration/gnome-terminal/ for a example.

Ruby ruby-1.9.2-p320@Buildr-ci-matrix/BUILD_JVM=1.7,BUILD_RVM=1.9.2,label=ubuntu is not installed.
Installing bundler...
Ruby ruby-1.9.2-p320@Buildr-ci-matrix/BUILD_JVM=1.7,BUILD_RVM=1.9.2,label=ubuntu is not installed.
Ruby ruby-1.9.2-p320@Buildr-ci-matrix/BUILD_JVM=1.7,BUILD_RVM=1.9.2,label=ubuntu is not installed.
exec rake ci --trace

rvm 1.16.8 (stable) by Wayne E. Seguin <wayneeseguin@gmail.com>, Michal Papis <mpapis@gmail.com>
[https://rvm.io/]

Ruby ruby-1.9.2-p320@Buildr-ci-matrix/BUILD_JVM=1.7,BUILD_RVM=1.9.2,label=ubuntu is not installed.
Build step 'Execute shell' marked build as failure
Recording test results

Mime
View raw message