brooklyn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Duncan Grant (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (BROOKLYN-552) Tomcat entity stop / start fails as entity id changes which update run_dir but tc obviously not moved
Date Thu, 09 Nov 2017 15:20:00 GMT

    [ https://issues.apache.org/jira/browse/BROOKLYN-552?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16245804#comment-16245804
] 

Duncan Grant commented on BROOKLYN-552:
---------------------------------------

Having also tested with solr I see different issues: errors like keypair doesn't exist or
security group doesn't exist.  This happens when the machine is "restarted" during a restart
or stop / start.

> Tomcat entity stop / start fails as entity id changes which update run_dir but tc obviously
not moved
> -----------------------------------------------------------------------------------------------------
>
>                 Key: BROOKLYN-552
>                 URL: https://issues.apache.org/jira/browse/BROOKLYN-552
>             Project: Brooklyn
>          Issue Type: Bug
>            Reporter: Duncan Grant
>            Priority: Critical
>
> Reproduce:
> Deploy tomcat with:
> name: Test Tomcat
> location:
> centos7_gce_europe
> services:
> type: org.apache.brooklyn.entity.webapp.tomcat.TomcatServer
> after entity is running do 
> br app <appid> ent <entityid> stop
> br app <appid> ent <entityid> start
> The isrunning check will never pass as the run_dir sensor will have upated but obviously
the directory is not moved on the vm
> This is presumably a problem with all blueprints that use the standard pid check for
running???



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message