brooklyn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aled Sage <aled.s...@gmail.com>
Subject [PROPOSAL] Delete "classic-mode" (always use Karaf)
Date Mon, 09 Oct 2017 11:13:04 GMT
Hi all,

I propose that we *delete* Brooklyn classic-mode from master now, in 
preparation for the 1.0.0 release.

---

In 0.12.0, we switched the main distro to be the karaf-mode. We also 
built the classic-mode distro - the intent being for users to have a 
usable classic mode, rather than being forced immediately to switch to 
karaf without advanced warning.

However, we unfortunately did not deprecate classic-mode as clearly as 
we should have (e.g. didn't explicitly say that it will be deleted in an 
upcoming release, and didn't deprecate the `Main` class).

I think it's still ok to delete it for several reasons:

 1. This is a "mode" of running Brooklyn, rather than underlying
    Brooklyn functionality.
 2. The `Main` class [1] etc should not be considered part of our
    *public* API (even though we didn't explicitly tell people that it
    was internal).
 3. As part of 0.12.0 release, we added to the docs instructions for
    upgrading to Karaf [2].
 4. Supporting classic to the same standard as Karaf will become
    increasingly painful as we do more and more with Bundles!
 5. It's a major release, so if we are going to delete it then 1.0.0 is
    the perfect time!

Aled

[1] 
https://github.com/apache/brooklyn-server/blob/master/server-cli/src/main/java/org/apache/brooklyn/cli/Main.java

[2] 
http://brooklyn.apache.org/v/0.12.0/ops/upgrade.html#upgrade-from-apache-brooklyn-0110-and-below



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message