brooklyn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From neykov <...@git.apache.org>
Subject [GitHub] brooklyn-server issue #740: New versioning rules prep
Date Thu, 29 Jun 2017 07:14:35 GMT
Github user neykov commented on the issue:

    https://github.com/apache/brooklyn-server/pull/740
  
    > for other things yes it will be surprising but someone making an OSGi bundle relying
on that converter's obscure behaviour is asking for trouble
    
    That's everyone using maven. When the bundle's version is different from the catalog.bom's
derived OSGi version Brooklyn will deny loading the file, right? If so we should just say
that we are not supporting non-standard versions (and not accept them from the start) instead
of documenting the format as deprecated, but working and letting the user find out if it works
or not for them. Wdyt?


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.
---

Mime
View raw message