brooklyn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rupinder Singh <rupi....@gmail.com>
Subject Re: Failing to deploy
Date Mon, 08 May 2017 16:34:19 GMT
Hi Andrea,

I'd expected somebody would revert to me on the forward below. Awaiting.
Regards,
Rupinder.

PS: As onlooker, I find the efforts put in to build consesus on new PR
standards commendable. Kudos to Alex Henevald to raise and to Richard to
build consensus!  That feedback of Linux maintainer is a turner.
On 30 Apr 2017 08:33, "Rupinder Singh" <rupi.pal@gmail.com> wrote:

> Hi Andrea,
>
> I'm sorry for the delay in reverting. I was busy elsewhere; also, I 'd to
> catch up some learning in this area.
>
> 1.I'm using Windows 7. I'm little bit unable to understand as to which
> default SSH keys will Brooklyn try to inject while creating VM and
> subsequently logging into it. Which is why, with ubuntu, I guess, I'm
> facing those issues.  As such, I thought of injecting SSH keys via yaml
> blueprint (as attached bp1), but I'm facing some other issues there as well.
>
> 2. In Trystack(OpenStack), for cirros image,  password authentication is
> available with given userid and password cirros and cubswin:)
> respectively. I tried that with blueprint(as attached bp2) in Brooklyn. It
> does create usable instance and I'm able to puTTY( apparently telnet) into
> it with those credentials.For all other OSes I'll have to SSH.
>
> I'm trying. I may need to to catchup some more reading. For time being, I
> hope I made little headway.
>
> regards
> Rupinder
>
>
>
> On Sat, Apr 22, 2017 at 2:05 PM, Andrea Turli <andrea.turli@cloudsoftcorp.
> com> wrote:
>
>> Rupinder,
>>
>> I'm quite confused now, could you please share the manual steps from
>> nothing to the ssh access to the instance created with that imageId. I'm
>> particularly interested in the account available on that image you can use
>> to access via ssh.
>>
>> Thanks,
>> Andrea
>>
>> On 21 April 2017 at 17:15, Rupinder Singh <rupi.pal@gmail.com> wrote:
>>
>> > Hi Thomas,
>> >
>> > I hadn't deleted the image. I had deleted the instance created by
>> Brooklyn.
>> > Anyway, I retried both with osFamily and osVersionRegex and ImageId as
>> per
>> > attached blueprints. The results are as before. With ImageId, at least
>> > something shows up in TryStack dashboard, beforelong it gives error.
>> With
>> > osFamily and osVesionRegex, nothing seems to happen. Logs are here.
>> >
>> > https://drive.google.com/file/d/0B9xR8_XMSxDSMWtjOTBMYW9xSVU/view?
>> > usp=sharing
>> > https://drive.google.com/file/d/0B9xR8_XMSxDSS0Y3aDdIQWoyaHM/view?
>> > usp=sharing
>> > https://drive.google.com/file/d/0B9xR8_XMSxDSU3FkSW9PRkVOeW8/view?
>> > usp=sharing
>> >
>> > Thanks for your continued support!
>> > Rupinder
>> >
>> > On Wed, Apr 19, 2017 at 3:35 PM, Rupinder Singh <rupi.pal@gmail.com>
>> > wrote:
>> >
>> > > hi Thomas. The imageId is a unintentional miss. I'll redo. Thanks
>> > >
>> > > Rupinder.
>> > > On 19 Apr 2017 15:09, "Thomas Bouron" <thomas.bouron@cloudsoftcorp.c
>> om>
>> > > wrote:
>> > >
>> > >> Hi Rupinder.
>> > >>
>> > >> I noticed you didn't update the `imageId` parameter compared to the
>> last
>> > >> blueprint you sent. If you deleted this specific image, it does not
>> > >> surprise me that Brooklyn cannot find it.
>> > >> I would strongly suggest that you use the combination of `osFamily`
>> and
>> > >> `osVersionRegex`[1] instead of `imageId` to be more flexible about
>> what
>> > >> Brooklyn can pick.
>> > >>
>> > >> Also, I just noticed that you indent the values of the provisioning
>> > >> parameters. Maybe this has an influence on the parser so but I'm not
>> > sure
>> > >> about that. Maybe another contributor can confirm this?
>> > >>
>> > >> Hope it will work this time.
>> > >>
>> > >> Best.
>> > >>
>> > >> [1]
>> > >> https://brooklyn.apache.org/v/latest/ops/locations/index.
>> > html#vm-creation
>> > >>
>> > >> On Tue, 18 Apr 2017 at 17:55 Rupinder Singh <rupi.pal@gmail.com>
>> wrote:
>> > >>
>> > >> > Hi Thomas,
>> > >> >
>> > >> > I re-tried , after deleting that instance in TryStack. The
>> situation
>> > >> > remains the same. Logs attached.
>> > >> >
>> > >> > Additionally, I tried by putting mitaka jars in lib\patch. An
tried
>> > >> > deploying. Not authorized exception takes place.
>> > >> >
>> > >> > I also tried to list servers with a jclouds program(attached).
It
>> > >> correctly
>> > >> > lists that instance, unlike brooklyn.
>> > >> >
>> > >> > https://drive.google.com/file/d/0B9xR8_XMSxDSTlp3bUFPMzRrZzB
>> > >> > XVUR2OWdOTGR5OERyTFFR/view?usp=sharing
>> > >> >
>> > >> > https://drive.google.com/file/d/0B9xR8_XMSxDSbktWM3BZcW9lMWx
>> > >> > zMVQwaGdKRjJfc2VBUXFR/view?usp=sharing
>> > >> >
>> > >> > https://drive.google.com/file/d/0B9xR8_XMSxDSRzhGZUE5UEFveEx
>> > >> > qOFpWYXllbzJPVHRiZ1Fz/view?usp=sharing
>> > >> >
>> > >> > https://drive.google.com/file/d/0B9xR8_XMSxDScTRMbnduanYxNVk
>> > >> > /view?usp=sharing
>> > >> >
>> > >> > https://drive.google.com/file/d/0B9xR8_XMSxDSQl9ZSzBsU1YyT2U
>> > >> > wTVBkMXAxa0VIcnotNVZr/view?usp=sharing
>> > >> >
>> > >> > https://drive.google.com/file/d/0B9xR8_XMSxDSdkt1TWg5VGxqOFE
>> > >> > /view?usp=sharing
>> > >> >
>> > >> > regards
>> > >> >
>> > >> > Rupinder
>> > >> >
>> > >> >
>> > >> > On Tue, Apr 18, 2017 at 10:12 PM, Rupinder Singh <
>> rupi.pal@gmail.com>
>> > >> > wrote:
>> > >> >
>> > >> > > Hi Thomas,
>> > >> > >
>> > >> > > I re-tried , after deleting that instance in TryStack. The
>> situation
>> > >> > > remains the same. Logs attached.
>> > >> > >
>> > >> > > Additionally, I tried by putting mitaka jars in lib\patch.
An
>> tried
>> > >> > > deploying. Not authorized exception takes place.
>> > >> > >
>> > >> > > I also tried to list servers with a jclouds program(attached).
It
>> > >> > > correctly lists that instance, unlike brooklyn.
>> > >> > >
>> > >> > > https://drive.google.com/file/d/0B9xR8_XMSxDSTlp3bUFPMzRrZzB
>> > >> > > XVUR2OWdOTGR5OERyTFFR/view?usp=sharing
>> > >> > >
>> > >> > > https://drive.google.com/file/d/0B9xR8_XMSxDSbktWM3BZcW9lMWx
>> > >> > > zMVQwaGdKRjJfc2VBUXFR/view?usp=sharing
>> > >> > >
>> > >> > > https://drive.google.com/file/d/0B9xR8_XMSxDSRzhGZUE5UEFveEx
>> > >> > > qOFpWYXllbzJPVHRiZ1Fz/view?usp=sharing
>> > >> > >
>> > >> > > https://drive.google.com/file/d/0B9xR8_XMSxDScTRMbnduanYxNVk
>> > >> > > /view?usp=sharing
>> > >> > >
>> > >> > > https://drive.google.com/file/d/0B9xR8_XMSxDSQl9ZSzBsU1YyT2U
>> > >> > > wTVBkMXAxa0VIcnotNVZr/view?usp=sharing
>> > >> > >
>> > >> > > https://drive.google.com/file/d/0B9xR8_XMSxDSdkt1TWg5VGxqOFE
>> > >> > > /view?usp=sharing
>> > >> > >
>> > >> > > regards
>> > >> > >
>> > >> > > Rupinder
>> > >> > >
>> > >> > >
>> > >> > > On Mon, Apr 17, 2017 at 8:13 PM, Thomas Bouron <
>> > >> > > thomas.bouron@cloudsoftcorp.com> wrote:
>> > >> > >
>> > >> > >> Hi Rupinder
>> > >> > >>
>> > >> > >> It makes sense for the user/password as you supplied
your own
>> > >> > >> user/password
>> > >> > >> in the blueprint. In this case, Brooklyn will connect
to the VM
>> > with
>> > >> the
>> > >> > >> default user, then create a new user (supplied by the
blueprint)
>> > and
>> > >> > >> finally disable the default user[1]
>> > >> > >>
>> > >> > >> However, I'm not really understanding what happens with
your
>> > >> deployment.
>> > >> > >> The debug logs say:
>> > >> > >>
>> > >> > >> 017-04-17 05:18:36,258 DEBUG jclouds.compute
>> > >> > >> [brooklyn-execmanager-ZM1RaPwv-3]: <<   matched
>> > >> > >> image(RegionOne/76f5f4aa-a78f-4703-b738-cab967957431)
>> > >> > >> hardware(RegionOne/2) location(RegionOne)
>> > >> > >>
>> > >> > >>
>> > >> > >> and the machine is provisioned. But there error message
I can
>> see
>> > >> later
>> > >> > in
>> > >> > >> the logs suggested that the VM was not even created:
>> > >> > >>
>> > >> > >> 2017-04-17 05:48:44,587 ERROR jclouds.compute [user thread
0]:
>> > >> > >> createNodesInGroup(brooklyn-ooj0sw-nwe-server3-brookly-wp0w-
>> > >> my-vm-g4bb),
>> > >> > >> completed: 0/1, errors: 1, rate: 1806806ms/op
>> > >> > >> java.util.concurrent.ExecutionException:
>> > >> > >> java.lang.IllegalArgumentException: id must be in format
>> > regionId/id
>> > >> > >>
>> > >> > >>
>> > >> > >> Maybe someone with a deeper understanding of Brooklyn
with
>> > Openstack
>> > >> can
>> > >> > >> answer this?
>> > >> > >>
>> > >> > >> Best.
>> > >> > >>
>> > >> > >> [1] https://brooklyn.apache.org/v/
>> latest/ops/locations/index.htm
>> > >> > >> l#os-setup
>> > >> > >>
>> > >> > >> On Mon, 17 Apr 2017 at 15:09 Rupinder Singh <rupi.pal@gmail.com
>> >
>> > >> wrote:
>> > >> > >>
>> > >> > >> > Hi Thomas,
>> > >> > >> >
>> > >> > >> > I'd tried to deploy earlier in the morning. So those
were the
>> > >> logs. I
>> > >> > >> just
>> > >> > >> > happened to check TryStack dashboard moments ago.
I noticed
>> the
>> > >> Ubuntu
>> > >> > >> > intance running and active. However, it isn't accepting
the
>> user
>> > >> login
>> > >> > >> or
>> > >> > >> > password specified in the blueprint. Although, it
does show
>> > >> console of
>> > >> > >> > Ubuntu 16.04.
>> > >> > >> >
>> > >> > >> > Rupinder
>> > >> > >> >
>> > >> > >> > On Mon, Apr 17, 2017 at 6:45 PM, Rupinder Singh
<
>> > >> rupi.pal@gmail.com>
>> > >> > >> > wrote:
>> > >> > >> >
>> > >> > >> > > Hi Thomas,
>> > >> > >> > >
>> > >> > >> > > I removed minRam in the yaml and this time
an instance of
>> > ubuntu
>> > >> > 16.04
>> > >> > >> > did
>> > >> > >> > > show running in TrySStack dashboard. However,
it kept
>> starting
>> > >> for
>> > >> > too
>> > >> > >> > long
>> > >> > >> > > and then crashed. The blueprint and logs are
attached here.
>> > >> > >> > >
>> > >> > >> > > Rupinder
>> > >> > >> > >
>> > >> > >> > > On Mon, Apr 17, 2017 at 2:33 AM, Thomas Bouron
<
>> > >> > >> > > thomas.bouron@cloudsoftcorp.com> wrote:
>> > >> > >> > >
>> > >> > >> > >> Hi Rupinder.
>> > >> > >> > >>
>> > >> > >> > >> Looks like your Openstack does not have
the minimum
>> hardware
>> > >> > >> > requirements
>> > >> > >> > >> you specified in your blueprint:
>> > >> > >> > >>
>> > >> > >> > >> 2017-04-16 22:06:50,094 ERROR o.a.b.l.j.JcloudsLocation
>> > >> > >> > >> [brooklyn-execmanager-ZqOwXBDn-4]: Failed
to start VM for
>> > null
>> > >> > after
>> > >> > >> > >> 3.84s (semaphore obtained in 1ms;): Unable
to match
>> required
>> > VM
>> > >> > >> > >> template constraints PortableTemplateBuilder[ports=[22],
>> > >> > >> > >> imageId=RegionOne/76f5f4aa-a78f-4703-b738-cab967957431,
>> > >> > >> > >> imageChooserFunction=org.apache.brooklyn.location.jclouds.
>> > >> > >> > >> BrooklynImageChooser$ImageChooserFromOrdering,
>> > >> > >> > >> minRam=8000] when trying to provision VM
in
>> > >> > >> > >> JcloudsLocation[openstack-nova:http://8.43.86.2:5000/v2.0/
>> :
>> > >> > >> > >> facebook1939146382766976:facebook1939146382766976@
>> > c04b5y402d];
>> > >> > >> > >> see list of images in log. Root cause:
>> > >> > >> > >> java.util.NoSuchElementException: no hardware
profiles
>> match
>> > >> > params:
>> > >> > >> > >> Predicates.and(nullEqualToIsPa
>> rentOrIsGrandparentOfCurrentLo
>> > >> > >> > >> cation(),minCores(0.0),minRam(8000),minDisk(0.0))
>> > >> > >> > >>
>> > >> > >> > >>
>> > >> > >> > >> You should try to lower down the `minRam`
or removing it
>> > >> entirely.
>> > >> > If
>> > >> > >> > >> that's not acceptable, I would suggest
that you create your
>> > own
>> > >> > >> image +
>> > >> > >> > >> hardware to make sure it matches your requirements.
>> > >> > >> > >>
>> > >> > >> > >> Best.
>> > >> > >> > >>
>> > >> > >> > >> On Sun, 16 Apr 2017 at 18:12 Rupinder Singh
<
>> > rupi.pal@gmail.com
>> > >> >
>> > >> > >> wrote:
>> > >> > >> > >>
>> > >> > >> > >> > ---------- Forwarded message ----------
>> > >> > >> > >> > From: Rupinder Singh <rupi.pal@gmail.com>
>> > >> > >> > >> > Date: Sun, Apr 16, 2017 at 10:28 PM
>> > >> > >> > >> > Subject: Re: Failing to deploy
>> > >> > >> > >> > To: dev@brooklyn.apache.org
>> > >> > >> > >> >
>> > >> > >> > >> >
>> > >> > >> > >> > Hi Andrea,
>> > >> > >> > >> >
>> > >> > >> > >> > No problem!
>> > >> > >> > >> >
>> > >> > >> > >> > I tried that. Blueprints and logs
attached here. The
>> issue
>> > >> stays.
>> > >> > >> > >> >
>> > >> > >> > >> > Rupinder
>> > >> > >> > >> >
>> > >> > >> > >> > On Sun, Apr 16, 2017 at 8:22 PM, Andrea
Turli <
>> > >> > >> > >> > andrea.turli@cloudsoftcorp.com>
wrote:
>> > >> > >> > >> >
>> > >> > >> > >> >> Rupinder,
>> > >> > >> > >> >>
>> > >> > >> > >> >> I've noticed in your latest example
>> > >> > >> > >> >>
>> > >> > >> > >> >> location:
>> > >> > >> > >> >>
>> > >> > >> > >> >>  jclouds:openstack-nova:
>> > >> > >> > >> >>
>> > >> > >> > >> >>    ...
>> > >> > >> > >> >>
>> > >> > >> > >> >>    osFamily:     ubuntu
>> > >> > >> > >> >>
>> > >> > >> > >> >>    imageId:      RegionOne/76f5f4aa-a78f-4703-b
>> > >> 738-cab967957431
>> > >> > >> > >> >>
>> > >> > >> > >> >>    ...
>> > >> > >> > >> >>
>> > >> > >> > >> >>
>> > >> > >> > >> >>
>> > >> > >> > >> >> Could you try the following:
>> > >> > >> > >> >>
>> > >> > >> > >> >>
>> > >> > >> > >> >>
>> > >> > >> > >> >> location:
>> > >> > >> > >> >>
>> > >> > >> > >> >>  jclouds:openstack-nova:
>> > >> > >> > >> >>
>> > >> > >> > >> >>    ...
>> > >> > >> > >> >>
>> > >> > >> > >> >>    imageId:      RegionOne/76f5f4aa-a78f-4703-b
>> > >> 738-cab967957431
>> > >> > >> > >> >>
>> > >> > >> > >> >>    ...
>> > >> > >> > >> >>
>> > >> > >> > >> >> Thanks for your perseverance and
sorry for the long
>> > >> > >> throubleshooting
>> > >> > >> > >> >> session,
>> > >> > >> > >> >> Andrea
>> > >> > >> > >> >>
>> > >> > >> > >> >>
>> > >> > >> > >> >>
>> > >> > >> > >> > --
>> > >> > >> > >>
>> > >> > >> > >> Thomas Bouron • Senior Software Engineer
@ Cloudsoft
>> > >> Corporation •
>> > >> > >> > >> https://cloudsoft.io/
>> > >> > >> > >> Github: https://github.com/tbouron
>> > >> > >> > >> Twitter: https://twitter.com/eltibouron
>> > >> > >> > >>
>> > >> > >> > >
>> > >> > >> > >
>> > >> > >> >
>> > >> > >> --
>> > >> > >>
>> > >> > >> Thomas Bouron • Senior Software Engineer @ Cloudsoft
>> Corporation •
>> > >> > >> https://cloudsoft.io/
>> > >> > >> Github: https://github.com/tbouron
>> > >> > >> Twitter: https://twitter.com/eltibouron
>> > >> > >>
>> > >> > >
>> > >> > >
>> > >> > >
>> > >> > >
>> > >> >
>> > >> --
>> > >>
>> > >> Thomas Bouron • Senior Software Engineer @ Cloudsoft Corporation
•
>> > >> https://cloudsoft.io/
>> > >> Github: https://github.com/tbouron
>> > >> Twitter: https://twitter.com/eltibouron
>> > >>
>> > >
>> >
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message