brooklyn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aled Sage <aled.s...@gmail.com>
Subject Re: Failing to deploy
Date Thu, 13 Apr 2017 09:38:35 GMT
Hi,

For the trystack deployment, your pastebin shows an exception while 
jclouds is trying to destroy the node (presumably because of an earlier 
error). It expects the VM's id to be in the format "regionId/id". It got 
this id by calling the OpenStack api's Get_Server_Details.

Unfortunately your pastebin does not include the earlier errors (it 
starts in the middle of an earlier exception's stacktrace). Do you have 
the debug log that you can share (ensuring any credentials are stripping 
out first - feel free to send the log to me privately if you don't want 
to share with the entire list).

What version of OpenStack are you using?

Note that Brooklyn 0.11.0 will hopefully be released in the next couple 
of weeks, which will include an upgrade to jclouds 2.0.1. That version 
of jclouds much better supports OpenStack releases from Mitaka onwards. 
You could test with 0.11.0 R1 (which was sent to the dev@brooklyn 
mailing list) if you like.

Aled

p.s. I see from the screenshot you're provisioning openSUSE 13.2. Once 
you get past this VM provisioning problem, that might cause problems - 
we test the Tomcat blueprint mainly on CentOS, and some testing on Ubuntu.


On 13/04/2017 10:30, Rupinder Singh wrote:
> Hi Guglielmo,
>
> For l localhost deployment,
>
> yaml: https://pastebin.com/BtuU74yG
>
> brooklun output: https://pastebin.com/REGwLnWz
>
> br output: https://pastebin.com/sihThbK1
>
>
>
> Rupinder
>
> On Thu, Apr 13, 2017 at 2:22 PM, Guglielmo Nigri <
> guglielmo.nigri@cloudsoftcorp.com> wrote:
>
>> Hi Rupinder,
>>
>> The yaml is missing, can you post it to pastebin as well, maybe?
>> It would also help to see the logs for the localhost deployment, too.
>>
>> Cheers,
>>
>> Guglielmo
>>
>> On 13 April 2017 at 05:49, Rupinder Singh <rupi.pal@gmail.com> wrote:
>>
>>> Hi,
>>>
>>> I'm using 0.10.0 on windows 7. I'm trying to deploy a tomcat to either to
>>> trystack or to localhost(of course, with yaml modified) as per the
>>>   attached yaml. The outputs are
>>>
>>> Brooklyn output: https://pastebin.com/14kEhzRK
>>>
>>> Br Output: https://pastebin.com/nuGssySt
>>>
>>>
>>> Trystack status keeps showing as attached.
>>>
>>>
>>>
>>> After taking a lot of time to start, it declares ERROR. It meets the same
>>> fate on localhost.
>>>
>>>
>>> Rupinder
>>>


Mime
View raw message