brooklyn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rupinder Singh <rupi....@gmail.com>
Subject Re: Failing to deploy
Date Mon, 17 Apr 2017 14:09:46 GMT
Hi Thomas,

I'd tried to deploy earlier in the morning. So those were the logs. I just
happened to check TryStack dashboard moments ago. I noticed the Ubuntu
intance running and active. However, it isn't accepting the user login or
password specified in the blueprint. Although, it does show console of
Ubuntu 16.04.

Rupinder

On Mon, Apr 17, 2017 at 6:45 PM, Rupinder Singh <rupi.pal@gmail.com> wrote:

> Hi Thomas,
>
> I removed minRam in the yaml and this time an instance of ubuntu 16.04 did
> show running in TrySStack dashboard. However, it kept starting for too long
> and then crashed. The blueprint and logs are attached here.
>
> Rupinder
>
> On Mon, Apr 17, 2017 at 2:33 AM, Thomas Bouron <
> thomas.bouron@cloudsoftcorp.com> wrote:
>
>> Hi Rupinder.
>>
>> Looks like your Openstack does not have the minimum hardware requirements
>> you specified in your blueprint:
>>
>> 2017-04-16 22:06:50,094 ERROR o.a.b.l.j.JcloudsLocation
>> [brooklyn-execmanager-ZqOwXBDn-4]: Failed to start VM for null after
>> 3.84s (semaphore obtained in 1ms;): Unable to match required VM
>> template constraints PortableTemplateBuilder[ports=[22],
>> imageId=RegionOne/76f5f4aa-a78f-4703-b738-cab967957431,
>> imageChooserFunction=org.apache.brooklyn.location.jclouds.
>> BrooklynImageChooser$ImageChooserFromOrdering,
>> minRam=8000] when trying to provision VM in
>> JcloudsLocation[openstack-nova:http://8.43.86.2:5000/v2.0/:
>> facebook1939146382766976:facebook1939146382766976@c04b5y402d];
>> see list of images in log. Root cause:
>> java.util.NoSuchElementException: no hardware profiles match params:
>> Predicates.and(nullEqualToIsParentOrIsGrandparentOfCurrentLo
>> cation(),minCores(0.0),minRam(8000),minDisk(0.0))
>>
>>
>> You should try to lower down the `minRam` or removing it entirely. If
>> that's not acceptable, I would suggest that you create your own image +
>> hardware to make sure it matches your requirements.
>>
>> Best.
>>
>> On Sun, 16 Apr 2017 at 18:12 Rupinder Singh <rupi.pal@gmail.com> wrote:
>>
>> > ---------- Forwarded message ----------
>> > From: Rupinder Singh <rupi.pal@gmail.com>
>> > Date: Sun, Apr 16, 2017 at 10:28 PM
>> > Subject: Re: Failing to deploy
>> > To: dev@brooklyn.apache.org
>> >
>> >
>> > Hi Andrea,
>> >
>> > No problem!
>> >
>> > I tried that. Blueprints and logs attached here. The issue stays.
>> >
>> > Rupinder
>> >
>> > On Sun, Apr 16, 2017 at 8:22 PM, Andrea Turli <
>> > andrea.turli@cloudsoftcorp.com> wrote:
>> >
>> >> Rupinder,
>> >>
>> >> I've noticed in your latest example
>> >>
>> >> location:
>> >>
>> >>  jclouds:openstack-nova:
>> >>
>> >>    ...
>> >>
>> >>    osFamily:     ubuntu
>> >>
>> >>    imageId:      RegionOne/76f5f4aa-a78f-4703-b738-cab967957431
>> >>
>> >>    ...
>> >>
>> >>
>> >>
>> >> Could you try the following:
>> >>
>> >>
>> >>
>> >> location:
>> >>
>> >>  jclouds:openstack-nova:
>> >>
>> >>    ...
>> >>
>> >>    imageId:      RegionOne/76f5f4aa-a78f-4703-b738-cab967957431
>> >>
>> >>    ...
>> >>
>> >> Thanks for your perseverance and sorry for the long throubleshooting
>> >> session,
>> >> Andrea
>> >>
>> >>
>> >>
>> > --
>>
>> Thomas Bouron • Senior Software Engineer @ Cloudsoft Corporation •
>> https://cloudsoft.io/
>> Github: https://github.com/tbouron
>> Twitter: https://twitter.com/eltibouron
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message