brooklyn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nie Kun (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (BROOKLYN-441) OpenStack deploy vm fails: get wrong loginUser
Date Tue, 21 Feb 2017 09:32:44 GMT

     [ https://issues.apache.org/jira/browse/BROOKLYN-441?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Nie Kun updated BROOKLYN-441:
-----------------------------
    Description: 
I am trying to launch a instance on openstack via brooklyn
My yaml file was like below:
*
name: test
location:
  jclouds:openstack-mitaka-nova:
    endpoint: https://10.10.0.10:5000/v2.0
    identity: XXXXX
    credential: XXXXXX
services:
- type: brooklyn.entity.basic.EmptySoftwareProcess
  name: test1
  provisioning.properties:
    osFamily: CentOS
    osVersionRegex: 7
    hardwareId: RegionOne/3
    imageId: RegionOne/a9eab8c3-8e3c-4e68-8af2-02e9b5915a58
    loginUser: centos
    loginUser.privateKeyFile: /home/ubuntu/.ssh/id_rsa
    templateOptions:
      networks: ["3f4ca47b-6e04-449b-a44f-7cbc5696084d"]
      securityGroups: ["default", "SSH"]
      generateKeyPair: false
      keyPairName: niekun_openstack_de
*
I specify the loginUser: centos in the yaml file
But from the log file I saw that brooklyn still trying ssh to the instance by using ubuntu
user.
I don't know why this happened. It seems like the loginUser: centos does't work.
Below are the brooklyn's log

2017-02-21 09:07:44,202 DEBUG o.a.b.l.ssh.SshMachineLocation [brooklyn-execmanager-dNzOCrw1-174]:
SshMachineLocation[SshMachineLocation:yndl:ubuntu@192.168.1.118/192.168.1.118:22(id=yndlps9c9z)]
invalidating all entries in ssh pool cache. Final stats: CacheStats{hitCount=0, missCount=1,
loadSuccessCount=1, loadExceptionCount=0, totalLoadTime=111485, evictionCount=0}

I think this is a bug

  was:
I am trying to launch a instance on openstack via brooklyn
My yaml file was like below:
name: test
location:
  jclouds:openstack-mitaka-nova:
    endpoint: https://10.10.0.10:5000/v2.0
    identity: XXXXX
    credential: XXXXXX
services:
- type: brooklyn.entity.basic.EmptySoftwareProcess
  name: test1
  provisioning.properties:
    osFamily: CentOS
    osVersionRegex: 7
    hardwareId: RegionOne/3
    imageId: RegionOne/a9eab8c3-8e3c-4e68-8af2-02e9b5915a58
    loginUser: centos
    loginUser.privateKeyFile: /home/ubuntu/.ssh/id_rsa
    templateOptions:
      networks: ["3f4ca47b-6e04-449b-a44f-7cbc5696084d"]
      securityGroups: ["default", "SSH"]
      generateKeyPair: false
      keyPairName: niekun_openstack_de
I specify the loginUser: centos in the yaml file
But from the log file I saw that brooklyn still trying ssh to the instance by using ubuntu
user.
I don't know why this happened. It seems like the loginUser: centos does't work.
Below are the brooklyn's log

2017-02-21 09:07:44,202 DEBUG o.a.b.l.ssh.SshMachineLocation [brooklyn-execmanager-dNzOCrw1-174]:
SshMachineLocation[SshMachineLocation:yndl:ubuntu@192.168.1.118/192.168.1.118:22(id=yndlps9c9z)]
invalidating all entries in ssh pool cache. Final stats: CacheStats{hitCount=0, missCount=1,
loadSuccessCount=1, loadExceptionCount=0, totalLoadTime=111485, evictionCount=0}

I think this is a bug


> OpenStack deploy vm fails: get wrong loginUser
> ----------------------------------------------
>
>                 Key: BROOKLYN-441
>                 URL: https://issues.apache.org/jira/browse/BROOKLYN-441
>             Project: Brooklyn
>          Issue Type: Bug
>    Affects Versions: 0.10.0
>         Environment: brooklyn v0.10 openstack liberty
>            Reporter: Nie Kun
>
> I am trying to launch a instance on openstack via brooklyn
> My yaml file was like below:
> *
> name: test
> location:
>   jclouds:openstack-mitaka-nova:
>     endpoint: https://10.10.0.10:5000/v2.0
>     identity: XXXXX
>     credential: XXXXXX
> services:
> - type: brooklyn.entity.basic.EmptySoftwareProcess
>   name: test1
>   provisioning.properties:
>     osFamily: CentOS
>     osVersionRegex: 7
>     hardwareId: RegionOne/3
>     imageId: RegionOne/a9eab8c3-8e3c-4e68-8af2-02e9b5915a58
>     loginUser: centos
>     loginUser.privateKeyFile: /home/ubuntu/.ssh/id_rsa
>     templateOptions:
>       networks: ["3f4ca47b-6e04-449b-a44f-7cbc5696084d"]
>       securityGroups: ["default", "SSH"]
>       generateKeyPair: false
>       keyPairName: niekun_openstack_de
> *
> I specify the loginUser: centos in the yaml file
> But from the log file I saw that brooklyn still trying ssh to the instance by using ubuntu
user.
> I don't know why this happened. It seems like the loginUser: centos does't work.
> Below are the brooklyn's log
> 2017-02-21 09:07:44,202 DEBUG o.a.b.l.ssh.SshMachineLocation [brooklyn-execmanager-dNzOCrw1-174]:
SshMachineLocation[SshMachineLocation:yndl:ubuntu@192.168.1.118/192.168.1.118:22(id=yndlps9c9z)]
invalidating all entries in ssh pool cache. Final stats: CacheStats{hitCount=0, missCount=1,
loadSuccessCount=1, loadExceptionCount=0, totalLoadTime=111485, evictionCount=0}
> I think this is a bug



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message