brooklyn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sam Corbett (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (BROOKLYN-252) RiakCluster failed to launch on CentOS 7
Date Thu, 23 Feb 2017 16:29:44 GMT

    [ https://issues.apache.org/jira/browse/BROOKLYN-252?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15880784#comment-15880784
] 

Sam Corbett commented on BROOKLYN-252:
--------------------------------------

Neither {{openIptables}} nor {{stopIptables}} work consistently when deploying a Riak cluster
to a CentOS 7 instance in AWS with Brooklyn 0.11.0-SNAPSHOT. I ran several tests. Sometimes
the cluster formed, sometimes it didn't.

The cluster only formed consistently when I stopped {{firewalld}} (and disabled it for good
measure). I used this blueprint:

{code}
location: jclouds:aws-ec2:us-east-1
services:
- type: org.apache.brooklyn.entity.nosql.riak.RiakCluster
  id: cluster
  brooklyn.config:
    initialSize: 3
    memberSpec:
      $brooklyn:entitySpec:
        type: org.apache.brooklyn.entity.nosql.riak.RiakNode
        version: 2.0.5
        brooklyn.config:
          preInstallCommand: "sudo systemctl stop firewalld ; sudo systemctl disable firewalld"
{code}

AMI: RightImage_CentOS_7.0_x64_v14.2.1_HVM_EBS (ami-5492ba3c)
{code}
brooklyn@ip-172-31-13-22 ~]$ cat /etc/*release
CentOS Linux release 7.0.1406 (Core)
{code}

> RiakCluster failed to launch on CentOS 7
> ----------------------------------------
>
>                 Key: BROOKLYN-252
>                 URL: https://issues.apache.org/jira/browse/BROOKLYN-252
>             Project: Brooklyn
>          Issue Type: Bug
>    Affects Versions: 0.9.0
>            Reporter: Aled Sage
>
> With 0.9.0-rc4, I tried deploying the {{3-bash-web-and-riak-template}} example to AWS
eu-central-1, using AMI RightImage_CentOS_7.0_x64_v14.2.1_HVM_EBS (ami-70d3ee6d).
> The RiakCluster failed when executing the joinCluster command. The stdout of the ssh
command (which is executed on another node in the cluster) showed:
> {{Node riak@ec2-52-58-71-148.eu-central-1.compute.amazonaws.com is not reachable!}}
> Are the installation steps different for CentOS 7 in any way?



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message