brooklyn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rupinder Singh <rupi....@gmail.com>
Subject Re: Beginner's issue in launching brooklyn from vagrant
Date Mon, 20 Feb 2017 14:13:17 GMT
I have Compaq R191B. Virtualization option is not there in BIOS. Doesn't
support VT-X.

On Mon, Feb 20, 2017 at 1:06 AM, Valentin Aitken <
valentin.aitken@cloudsoftcorp.com> wrote:

> Hi Rupinder,
>
> The last log says vagrant cannot find rsync.
> Could you try installing and adding to PATH some Windows port of rsync?
> I suggest to try Cygwin [1].
>
> Valentin.
>
> [1] https://en.wikipedia.org/wiki/Cygwin
>
> На 19/02/17 в 18:25, Rupinder Singh написа:
>
>> Hi Mark, Duncan,
>>
>> Fresh output is as attached. Would this work?
>>
>> Rupinder
>>
>> On Sun, Feb 19, 2017 at 8:45 PM, Rupinder Singh <rupi.pal@gmail.com
>> <mailto:rupi.pal@gmail.com>> wrote:
>>
>>     Thanks Mark, Duncan!
>>
>>     I'll try out and revert.
>>
>>     Rupinder
>>
>>     On Sun, Feb 19, 2017 at 8:28 PM, Mark Mc Kenna
>>     <m4rkmckenna@gmail.com <mailto:m4rkmckenna@gmail.com>> wrote:
>>
>>         Hi Rupinder,
>>
>>         As Duncan said the ubuntu image is no longer supported by vagrant.
>>
>>         The updated centos7 version can be downloaded from the apache
>>         maven repo
>>         [1]
>>         It is worth noting that this is configured for the
>>         0.11.0-SNAPSHOT version
>>         of brooklyn. To change this please amend BROOKLYN_VERSION in
>>         servers.yaml
>>         [2].
>>
>>         I have confirmed the above is working for
>>         vagrant: 1.9.1
>>         virtualbox: 5.0.30 r112061
>>
>>         [1]
>>         https://repository.apache.org/content/groups/snapshots/org/a
>> pache/brooklyn/brooklyn-vagrant/0.11.0-SNAPSHOT/
>>         <https://repository.apache.org/content/groups/snapshots/org/
>> apache/brooklyn/brooklyn-vagrant/0.11.0-SNAPSHOT/>
>>         [2]
>>         https://github.com/apache/brooklyn-dist/blob/master/vagrant/
>> src/main/vagrant/servers.yaml#L50
>>         <https://github.com/apache/brooklyn-dist/blob/master/vagrant
>> /src/main/vagrant/servers.yaml#L50>
>>         ​
>>         Cheers​
>>
>>         *Mark McKenna*
>>
>>         *Web :: markmckenna.ie <http://markmckenna.ie>
>>         <http://markmckenna.ie/>*
>>
>>         *Work :: mark.mckenna@cloudsoft.io
>>         <mailto:mark.mckenna@cloudsoft.io> <mark.mckenna@cloudsoft.io
>>         <mailto:mark.mckenna@cloudsoft.io>>*
>>
>>         *PGP :: A7A9 24DE 638C 681A 8DEA FAD4 2B5D C759 B1EB 76A7
>>         <https://pgp.mit.edu/pks/lookup?op=get&search=0x2B5DC759B1EB76A7
>>         <https://pgp.mit.edu/pks/lookup?op=get&search=0x2B5DC759B1EB76A7
>> >>*
>>
>>         On 19 February 2017 at 13:15, Duncan Godwin
>>         <duncan.godwin@cloudsoftcorp.com
>>         <mailto:duncan.godwin@cloudsoftcorp.com>
>>         > wrote:
>>
>>         > Hi Rupinder
>>         >
>>         > So I imagine the version of Ubuntu used in the vagrant
>>         example is no
>>         > longer supported. Fortunately this was upgraded a few weeks
>>         ago to centos
>>         > 7. This is expected in version 0.11 but is currently
>>         available in the
>>         > snapshot version here:
>>         >
>>         > https://brooklyn.apache.org/meta/versions.html
>>         <https://brooklyn.apache.org/meta/versions.html>
>>         >
>>         > Thanks
>>         >
>>         > Duncan
>>         >
>>         >
>>         >
>>         > On 19 Feb 2017 13:08, "Richard Downer" <richard@apache.org
>>         <mailto:richard@apache.org>> wrote:
>>         >
>>         > Hi Rupinder,
>>         >
>>         > A few months back on an unrelated project I had a similar
>>         problem and it
>>         > was caused by a bug in Vagrant on Windows. I can't remember
>>         the details and
>>         > I'm on the road at the moment so I can't look it up, but it
>>         may be worth
>>         > searching Google for the error message. When I'm back in the
>>         office I'll
>>         > see if I can find more details for you.
>>         >
>>         > Sent from my Android phone
>>         >
>>         > On 19 Feb 2017 1:35 a.m., "Rupinder Singh"
>>         <rupi.pal@gmail.com <mailto:rupi.pal@gmail.com>> wrote:
>>         >
>>         > Hi Mark,
>>         >
>>         > The output from those two commands is as attached.
>>         >
>>         > vagrant version is 1.9.1
>>         >
>>         > thanks
>>         >
>>         > On Sat, Feb 18, 2017 at 10:54 PM, Mark Mc Kenna
>>         <m4rkmckenna@gmail.com <mailto:m4rkmckenna@gmail.com>>
>>         > wrote:
>>         >
>>         > > Hi Rupinder,
>>         > > Can you try running the below commands and provide the
>>         output ... Also
>>         > can
>>         > > you provide the vagrant version
>>         > >
>>         > > vagrant box add ubuntu/wily64
>>         > > vagrant up
>>         > >
>>         > > Cheers
>>         > > Mark
>>         > >
>>         > > On 18 Feb 2017 16:44, "Rupinder Singh" <rupi.pal@gmail.com
>>         <mailto:rupi.pal@gmail.com>> wrote:
>>         > >
>>         > > I am beginner in brooklyn. I am trying to bring up
>>         brooklyn from vagrant
>>         > on
>>         > > my windows 7 machine. I am getting 404 error
>>         > >
>>         > > downloading
>>         > > https://atlas.hashicorp.com/ubuntu/boxes/wily64/versions/
>>         <https://atlas.hashicorp.com/ubuntu/boxes/wily64/versions/>
>>         > > 20160715.0.0/providers/virtualbox
>>         > >
>>         > > thats from where it says. file not found 404
>>         > >
>>         > > can anybody help?
>>         > >
>>         >
>>         >
>>         >
>>
>>
>>
>>
> --
> Valentin Aitken
> Software Engineer
> Cloudsoft Corporation Ltd.
> www.cloudsoft.io
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message