brooklyn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gowri LN <gowri.ln...@gmail.com>
Subject Re: Need help in deploying Brooklyn on OpenStack liberty
Date Tue, 24 Jan 2017 10:43:45 GMT
HI ,

Apologies for missing out the details .

Broooklyn version: 0.9
Openstack: Liberty

I tried the yaml  , but it fails with the following :
2017-01-24 10:31:00,310 INFO  jclouds.ssh [user thread 3]: <<
(root:pw[6b2b5123d93d5716862e146ba2a83060]@30.30.10.83:22) error acquiring
{hostAndPort=x.x.x.x:22, loginUser=root, ssh=null, connectTimeout=60000,
sessionTimeout=60000} (attempt 11 of 50): Exhausted available
authentication methods
2017-01-24 10:31:00,310 DEBUG o.j.h.h.BackoffLimitedRetryHandler [user
thread 3]: Retry 11/50: delaying for 2000 ms:
(root:pw[6b2b5123d93d5716862e146ba2a83060]@x.x.x.x:22) error acquiring
{hostAndPort=x.x.x.x:22, loginUser=root, ssh=null, connectTimeout=60000,
sessionTimeout=60000}: Exhausted available authentication methods

Stuck in  "provisioning" stage from around 40 mins

Any suggestions ?

On Tue, Jan 24, 2017 at 3:43 PM, Andrea Turli <
andrea.turli@cloudsoftcorp.com> wrote:

> Sorry Gowri,
>
> I've just seen an issue on my smoke test blueprint, it should be
>
> services:
> - type: server
> location:
>     jclouds:openstack-nova:
>         endpoint: http://x.x.x.x:5000/v2.0/
>         identity: "your-tenant:your-username"
>         credential: your-password
>
> Sorry,
> Andrea
>
> On 24 January 2017 at 11:09, Andrea Turli <andrea.turli@cloudsoftcorp.com>
> wrote:
>
> > Gowri,
> >
> > to triage your issue it is important to know (1) the brooklyn version you
> > are using, could you report that?
> >
> > Please try this smoke test blueprint for Openstack
> >
> > services:
> > - type: server
> > location:
> >     jclouds:clouds:openstack-nova:
> >         endpoint: http://x.x.x.x:5000/v2.0/
> >         identity: "your-tenant:your-username"
> >         credential: your-password
> >
> > of course, you'll need to replace `endpoint`, `identity`, `credential`
> and
> > attach (2) the brooklyn.debug.log produced by this test?
> >
> > Notice, the above location is the bare minimum which will almost
> certainly
> > need to be customized using the additional configuration keys like the
> > following
> >
> >         # imageId, hardwareId, and loginUser* are optional
> >         imageId: your-region-name/your-image-id
> >         hardwareId: your-region-name/your-flavor-id
> >         loginUser: 'ubuntu'
> >         loginUser.privateKeyFile: /path/to/your/privatekey
> >
> >         jclouds.openstack-nova.auto-generate-keypairs: false
> >         jclouds.openstack-nova.auto-create-floating-ips: true
> >
> >         templateOptions:
> >             networks: [ "your-network-id" ]
> >             floatingIpPoolNames: [ "your-floatingIp-pool" ]
> >             securityGroups: ['your-security-group']
> >
> >             # Optional if 'jclouds.openstack-nova.auto-
> generate-keypairs'
> > is assigned to 'true'
> >             keyPairName: "your-keypair"
> >
> > but don't add them just now, and let's try to identify the issues when
> > using the default values.
> >
> > Best
> > Andrea
> >
> > On 24 January 2017 at 09:52, Gowri LN <gowri.ln123@gmail.com> wrote:
> >
> >> Hi Andrea,
> >>
> >> Thanks for your mail.
> >>
> >> I tried as per the suggestions in link. I have Liberty version and could
> >> not try jclouds:openstack-mitaka-nova ( error 1below). I am using
> >> "openstack-devtest-compute" jar.
> >>
> >> The properties specified in the yaml are picked up for VM . I can now
> see
> >> my keypair, security group getting associated to VM . Also, the  Vm has
> a
> >> private IP and a floating IP assigned but still the deployment fails
> with
> >> error:
> >>
> >> >
> >> > java.lang.NullPointerException
> >> > at
> >> > org.apache.brooklyn.location.jclouds.JcloudsSshMachineLocati
> >> on.getSubnetIp(JcloudsSshMachineLocation.java:373)
> >> > at org.apache.brooklyn.core.location.Machines.getSubnetIp(Machi
> >> nes.java:65)
> >> > at
> >> > org.apache.brooklyn.entity.software.base.lifecycle.MachineLi
> >> fecycleEffectorTasks$PreStartTask.run(MachineLifecycleEffect
> >> orTasks.java:448)
> >> > at java.util.concurrent.Executors$RunnableAdapter.call(
> >> Executors.java:471)
> >> > at
> >> > org.apache.brooklyn.util.core.task.DynamicSequentialTask$Dst
> >> Job.call(DynamicSequentialTask.java:359)
> >> > at
> >> > org.apache.brooklyn.util.core.task.BasicExecutionManager$Sub
> >> missionCallable.call(BasicExecutionManager.java:519)
> >> > at java.util.concurrent.FutureTask.run(FutureTask.java:262)
> >> > at
> >> > java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPool
> >> Executor.java:1145)
> >> > at
> >> > java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoo
> >> lExecutor.java:615)
> >> > at java.lang.Thread.run(Thread.java:745)
> >>
> >>
> >> I tried with and without specifying subnet ID but still same error . And
> >> in
> >> addition the error I was facing before - " Key Pairs are required by
> >> options, but the extension is not available!" and "Floating are required
> >> by
> >> options, but the extension is not available!"   are not there now. I
> would
> >> really like to know if it is a mistake/config change required at
> openstack
> >> level as I need to use Brooklyn on Openstack itself.
> >>
> >> Any suggestions ?
> >>
> >>
> >> Error 1: Illegal parameter for 'location' (jclouds:openstack-mitaka-nova
> >> );
> >> not resolvable: NoSuchElementException: Cloud provider/API type
> >> openstack-mitaka-nova is not supported by jclouds
> >>
> >> Thanks
> >>
> >> On Mon, Jan 23, 2017 at 10:34 PM, Andrea Turli <
> >> andrea.turli@cloudsoftcorp.com> wrote:
> >>
> >> > Hi,
> >> >
> >> > sorry to hear about your issue. We’ve seen that a number of times and
> >> it is
> >> > generally dependent on the Openstack installation. Please have a look
> at
> >> > this troubleshooting section
> >> > https://brooklyn.apache.org/v/latest/ops/locations/index.
> html#openstack
> >> > and
> >> > let us know if that fix your problem.
> >> >
> >> > Best,
> >> > Andrea
> >> >
> >> > On 23 January 2017 at 11:20, Gowri LN <gowri.ln123@gmail.com> wrote:
> >> >
> >> > > HI ,
> >> > >
> >> > > I am back to  trying Brooklyn on our current openstack (liberty).
> But
> >> I
> >> > > have been facing similar issues. I have only one network configured
> >> for
> >> > my
> >> > > project .The yaml I tried is :
> >> > >
> >> > > name: VM - with subnet ID5
> >> > > services:
> >> > > - type: brooklyn.entity.basic.EmptySoftwareProcess
> >> > > location:
> >> > >   jclouds:openstack-devtest-compute:
> >> > >      endpoint: https://x.x.x.x:5000/v2.0/
> >> > >     identity: "project:username"
> >> > >     credential: password
> >> > >     # optional
> >> > >    imageId: RegionOne/image-id
> >> > >     hardwareId: RegionOne/2
> >> > >     loginUser: 'ubuntu'
> >> > >     loginUser.privateKeyFile: /path/to/keypair.pem
> >> > >     jclouds.openstack-nova.auto-generate-keypairs: false
> >> > >     templateOptions:
> >> > >      networks: [ "network-id" ]
> >> > >      securityGroups: ['securitygroupname']
> >> > >      keyPairName: "keypairname
> >> > >      subnetId: subnet-id-of-network
> >> > >
> >> > >
> >> > > The Vm gets created with a floating IP,my keypair  assigned this
> time
> >> .
> >> > But
> >> > > I still get the error at "pre start" stage:
> >> > > Failed after 4ms: NullPointerException
> >> > >
> >> > > java.lang.NullPointerException
> >> > > at
> >> > > org.apache.brooklyn.location.jclouds.JcloudsSshMachineLocation.
> >> > > getSubnetIp(JcloudsSshMachineLocation.java:373)
> >> > > at org.apache.brooklyn.core.location.Machines.getSubnetIp(
> >> > > Machines.java:65)
> >> > > at
> >> > > org.apache.brooklyn.entity.software.base.lifecycle.
> >> > > MachineLifecycleEffectorTasks$PreStartTask.run(
> >> > > MachineLifecycleEffectorTasks.java:448)
> >> > > at java.util.concurrent.Executors$RunnableAdapter.
> >> > call(Executors.java:471)
> >> > > at
> >> > > org.apache.brooklyn.util.core.task.DynamicSequentialTask$
> DstJob.call(
> >> > > DynamicSequentialTask.java:359)
> >> > > at
> >> > > org.apache.brooklyn.util.core.task.BasicExecutionManager$
> >> > > SubmissionCallable.call(BasicExecutionManager.java:519)
> >> > > at java.util.concurrent.FutureTask.run(FutureTask.java:262)
> >> > > at
> >> > > java.util.concurrent.ThreadPoolExecutor.runWorker(
> >> > > ThreadPoolExecutor.java:1145)
> >> > > at
> >> > > java.util.concurrent.ThreadPoolExecutor$Worker.run(
> >> > > ThreadPoolExecutor.java:615)
> >> > > at java.lang.Thread.run(Thread.java:745)
> >> > >
> >> > > Thanks for your help so far. Any suggestion for resolving this?
> >> > >
> >> > >
> >> > > Also we might setup a new openstack in sometime . Is there any
> >> specific
> >> > > configuration that you suggest which might make brooklyn deployments
> >> easy
> >> > > on Openstack ?
> >> > >
> >> > > Thanks
> >> > > Gowri
> >> > >
> >> > > On Mon, Jul 11, 2016 at 6:40 PM, Andrea Turli <
> >> > > andrea.turli@cloudsoftcorp.com> wrote:
> >> > >
> >> > > > Hi,
> >> > > >
> >> > > > could you check the status of the VM provisioned in your Openstack
> >> > > > instance? Does it have a private address and a floating ip address
> >> > > attached
> >> > > > to it?
> >> > > >
> >> > > > If not, I'd simplify the network templateOptions by removing
> >> > > > `floatingIpPoolNames`, `subnetId` and double-checking the
> >> "network-id"
> >> > > >
> >> > > > Andrea
> >> > > >
> >> > > > On 11 July 2016 at 13:20, Gowri LN <gowri.ln123@gmail.com>
wrote:
> >> > > >
> >> > > > > HI Andrea,
> >> > > > >
> >> > > > >
> >> > > > >
> >> > > > > The application fails at pre start . Is there anything that
I am
> >> > > missing
> >> > > > > out here ? I tried specifying the subnet ID as well as suggested
> >> in 1
> >> > > > > <https://brooklyn.apache.org/v/latest/ops/locations/>
but it
> >> still
> >> > > fails
> >> > > > > with null pointer exception.
> >> > > > >
> >> > > > > Sample Yaml :
> >> > > > > name: VM - with subnet ID
> >> > > > > services:
> >> > > > > - type: brooklyn.entity.basic.EmptySoftwareProcess
> >> > > > > location:
> >> > > > >   jclouds:openstack-devtest-compute:
> >> > > > >     endpoint: https://x.x.x.x:5000/v2.0/
> >> > > > >     identity: "project:username"
> >> > > > >     credential: password
> >> > > > >     # optional
> >> > > > >     imageId: RegionOne/image-id
> >> > > > >     hardwareId: RegionOne/2
> >> > > > >     loginUser: 'ubuntu'
> >> > > > >     loginUser.privateKeyFile: /path/to/keypair.pem
> >> > > > >     jclouds.openstack-nova.auto-generate-keypairs: false
> >> > > > >     templateOptions:
> >> > > > >       networks: [ "network-id" ]
> >> > > > >       subnetId: subnet-id-of-network
> >> > > > >       floatingIpPoolNames: [ "floating-ip-pool-name" ]
> >> > > > >       securityGroups: ['securitygroupname']
> >> > > > >       keyPairName: "keypairname"
> >> > > > >
> >> > > > > Log :
> >> > > > > Failed after 3ms: NullPointerException
> >> > > > >
> >> > > > > java.lang.NullPointerException
> >> > > > > at
> >> > > > >
> >> > > > > org.apache.brooklyn.location.jclouds.JcloudsSshMachineLocation.
> >> > > > getSubnetIp(JcloudsSshMachineLocation.java:373)
> >> > > > > at org.apache.brooklyn.core.location.Machines.getSubnetIp(
> >> > > > Machines.java:65)
> >> > > > > at
> >> > > > >
> >> > > > > org.apache.brooklyn.entity.software.base.lifecycle.
> >> > > > MachineLifecycleEffectorTasks$PreStartTask.run(
> >> > > > MachineLifecycleEffectorTasks.java:448)
> >> > > > > at java.util.concurrent.Executors$RunnableAdapter.
> >> > > > call(Executors.java:511)
> >> > > > > at
> >> > > > >
> >> > > > > org.apache.brooklyn.util.core.task.DynamicSequentialTask$
> >> > DstJob.call(
> >> > > > DynamicSequentialTask.java:359)
> >> > > > > at
> >> > > > >
> >> > > > > org.apache.brooklyn.util.core.task.BasicExecutionManager$
> >> > > > SubmissionCallable.call(BasicExecutionManager.java:519)
> >> > > > > at java.util.concurrent.FutureTask.run(FutureTask.java:266)
> >> > > > > at
> >> > > > >
> >> > > > > java.util.concurrent.ThreadPoolExecutor.runWorker(
> >> > > > ThreadPoolExecutor.java:1142)
> >> > > > > at
> >> > > > >
> >> > > > > java.util.concurrent.ThreadPoolExecutor$Worker.run(
> >> > > > ThreadPoolExecutor.java:617)
> >> > > > > at java.lang.Thread.run(Thread.java:745)
> >> > > > >
> >> > > > >
> >> > > > > Any help ?
> >> > > > >
> >> > > > > Thanks in advance .
> >> > > > >
> >> > > > > On Thu, Jun 30, 2016 at 6:16 PM, Gowri LN <
> gowri.ln123@gmail.com>
> >> > > wrote:
> >> > > > >
> >> > > > > > Hi ,
> >> > > > > >
> >> > > > > > I changed the  loginUser.privateKeyFile to point to
my key.pem
> >> > > instead
> >> > > > of
> >> > > > > > private key . This resolved the "doesn't contain %
line
> >> [-----BEGIN
> >> > > ]"
> >> > > > > > error .
> >> > > > > >
> >> > > > > > i.e  loginUser.privateKeyFile: / path/to/my/my-keypair.pem
> >> instead
> >> > > of
> >> > > > > > /path/to/my-keypair-private.ppk .
> >> > > > > >
> >> > > > > > Now  a VM gets created , gets a floating IP and assigns
my
> >> keypair
> >> > as
> >> > > > > well
> >> > > > > >  :) . I can ssh into VM using the keypair .
> >> > > > > > But , the application in Brooklyn turns to on fire
with null
> >> > pointer
> >> > > > > > exception.
> >> > > > > >
> >> > > > > > Debug log:
> >> > > > > >
> >> > > > > >>  OS credential inference:
> >> > > > > >> OsCredential[no-public-key;no-private-key,password(len=12)]
> >> > > > > >
> >> > > > > >
> >> > > > > >> 2016-06-30 11:08:31,440 DEBUG o.a.b.l.j.JcloudsSshMachineLoc
> >> ation
> >> > > > > >> [brooklyn-execmanager-PM0NSrkG-6]: Resolved subnet
hostname
> >> > x.x.x.x
> >> > > > for
> >> > > > > >> SshMachineLocation[x.x.x.x:ubuntu@x.x.x.x/x.x.x.x:22(id=
> >> > OX3nU7OP)]
> >> > > > > >
> >> > > > > > 2016-06-30 11:08:31,440 DEBUG o.a.b.core.location.Machines
> >> > > > > >> [brooklyn-execmanager-PM0NSrkG-6]: computed subnet
hostname
> >> > x.x.x.x
> >> > > > for
> >> > > > > >> SshMachineLocation[x.x.x.x:ubuntu@x.x.x.x/x.x.x.x:22(id=
> >> > OX3nU7OP)]
> >> > > > > >
> >> > > > > > 2016-06-30 11:08:31,441 DEBUG o.a.b.u.c.t.
> BasicExecutionManager
> >> > > > > >> [brooklyn-execmanager-PM0NSrkG-6]: Exception running
task
> >> > > > > >> Task[pre-start]@OmPQUIGb (rethrowing):
> >> > > java.lang.NullPointerException
> >> > > > > >
> >> > > > > > 2016-06-30 11:08:31,441 DEBUG o.a.b.u.core.task.CompoundTask
> >> > > > > >> [brooklyn-execmanager-PM0NSrkG-2]: Aborting secondary
job
> >> queue
> >> > for
> >> > > > > >> Task[start]@KbfqJrxf due to error in child task
> >> > > > Task[pre-start]@OmPQUIGb
> >> > > > > >> (java.util.concurrent.ExecutionException:
> >> > > > > java.lang.NullPointerException,
> >> > > > > >> being rethrown)
> >> > > > > >
> >> > > > > > 2016-06-30 11:08:31,441 DEBUG o.a.b.u.c.t.
> BasicExecutionManager
> >> > > > > >> [brooklyn-execmanager-PM0NSrkG-2]: Exception running
task
> >> > Task[DST
> >> > > > > manager
> >> > > > > >> (internal)]@cfSqj3nd (rethrowing):
> >> > > > > java.util.concurrent.ExecutionException:
> >> > > > > >> java.lang.NullPointerException
> >> > > > > >
> >> > > > > > 2016-06-30 11:08:31,452 DEBUG o.a.b.u.core.task.CompoundTask
> >> > > > > >> [brooklyn-execmanager-PM0NSrkG-0]: Parent task
> DstJob:KbfqJrxf
> >> > > > ignoring
> >> > > > > >> child error
> >> > > > > >> (org.apache.brooklyn.util.exceptions.PropagatedRuntimeExcept
> >> ion:
> >> > > > > >> NullPointerException) in presence of our own error
> >> > > > > >> (org.apache.brooklyn.util.exceptions.PropagatedRuntimeExcept
> >> ion:
> >> > > > > >> NullPointerException)
> >> > > > > >
> >> > > > > > 2016-06-30 11:08:31,453 WARN  o.a.b.c.m.i.EffectorUtils
> >> > > > > >> [brooklyn-execmanager-PM0NSrkG-0]: Error invoking
start at
> >> > > > > >> EmptySoftwareProcessImpl{id=OCLIVRf3}: NullPointerException
> >> > > > > >
> >> > > > > > 2016-06-30 11:08:31,454 DEBUG o.a.b.u.c.t.
> BasicExecutionManager
> >> > > > > >> [brooklyn-execmanager-PM0NSrkG-0]: Exception running
task
> >> > > > > >> Task[start]@KbfqJrxf (rethrowing):
> >> > > > > >>
> >> > > > > org.apache.brooklyn.core.mgmt.internal.EffectorUtils$
> >> > > > EffectorCallPropagatedRuntimeException:
> >> > > > > >> Error invoking start at EmptySoftwareProcessImpl{id=
> OCLIVRf3}:
> >> > > > > >> NullPointerException
> >> > > > > >
> >> > > > > >
> >> > > > > > Any suggestions ?
> >> > > > > >
> >> > > > > >>
> >> > > > > >
> >> > > > > > Thanks,
> >> > > > > > Gowri
> >> > > > > >
> >> > > > > > On Thu, Jun 30, 2016 at 11:52 AM, Andrea Turli <
> >> > > > > > andrea.turli@cloudsoftcorp.com> wrote:
> >> > > > > >
> >> > > > > >> Sorry forgot the link
> >> > > > > >>
> >> > > > > >> http://docs.openstack.org/user-guide/dashboard_launch_
> >> > > instances.html
> >> > > > > >>
> >> > > > > >> Il 30/giu/2016 08:18, "Andrea Turli"
> >> <andrea.turli@cloudsoftcorp.
> >> > > com>
> >> > > > > ha
> >> > > > > >> scritto:
> >> > > > > >>
> >> > > > > >> > Gowri,
> >> > > > > >> >
> >> > > > > >> > Same suggestion as before. Please follow the
first 2 points
> >> of
> >> > > this
> >> > > > > >> guide
> >> > > > > >> > [1] to verify that you can manually launch
and ssh into the
> >> VM.
> >> > > > > >> >
> >> > > > > >> > Please take notes of the choices you made
to provision the
> VM
> >> > > > > (imageId,
> >> > > > > >> > network and so on) and the user and ssh key
you used to
> >> access
> >> > the
> >> > > > VM.
> >> > > > > >> >
> >> > > > > >> > With those details, I'm sure you can then
configure the
> >> location
> >> > > in
> >> > > > > the
> >> > > > > >> > YAML blueprint correctly.
> >> > > > > >> >
> >> > > > > >> > Andrea
> >> > > > > >> >
> >> > > > > >> > Il 30/giu/2016 07:51, "Gowri LN" <gowri.ln123@gmail.com>
> ha
> >> > > > scritto:
> >> > > > > >> >
> >> > > > > >> > Hi Andrea,
> >> > > > > >> >
> >> > > > > >> > Thanks a lot for the constant support .
> >> > > > > >> >
> >> > > > > >> > I want to use my own keypair already available
in OpenStack
> >> so
> >> > > that
> >> > > > I
> >> > > > > >> can
> >> > > > > >> > connect to the  VM later using my keypair.
> >> > > > > >> >
> >> > > > > >> > I did try as specified in yaml [1].
> >> > > > > >> > Now it looks like it is picking up the keypair
(- may be it
> >> was
> >> > my
> >> > > > > >> error in
> >> > > > > >> > the yaml before).
> >> > > > > >> >
> >> > > > > >> > Though I am getting a new error :
> >> > > > > >> >
> >> > > > > >> >
> >> > > > > >> > > Error invoking start at EmptySoftwareProcessImpl{id=
> >> > TrmhitVc}:
> >> > > > chars
> >> > > > > >> > > PuTTY-User-Key-File-2: ssh-rsa
> >> > > > > >> > > Encryption: none
> >> > > > > >> > > Comment: imported-openssh-key
> >> > > > > >> > > Public-Lines: 6
> >> > > > > >> > > *..some lines...............*
> >> > > > > >> > > Private-Lines: 14 .
> >> > > > > >> >
> >> > > > > >> >
> >> > > > > >> >
> >> > > > > >> > > .. some lines...........
> >> > > > > >> > > Private-MAC: 37589......................57f
> >> > > > > >> > > doesn't contain % line [-----BEGIN ]
> >> > > > > >> > >
> >> > > > > >> >
> >> > > > > >> > The private key I am pointing in yaml is 
generated using
> >> putty
> >> > > gen
> >> > > > by
> >> > > > > >> > loading my key - "my-keypair"
> >> > > > > >> >
> >> > > > > >> > Any suggestions ?
> >> > > > > >> >
> >> > > > > >> >
> >> > > > > >> > [1]:
> >> > > > > >> https://gist.github.com/andreaturli/
> >> > 33509ff74bb8d0cfb77d5ba36c4697
> >> > > 7e
> >> > > > > >> >
> >> > > > > >> >
> >> > > > > >> >
> >> > > > > >> >
> >> > > > > >> >
> >> > > > > >> > On Mon, Jun 27, 2016 at 1:55 PM, Andrea Turli
<
> >> > > > > >> > andrea.turli@cloudsoftcorp.com> wrote:
> >> > > > > >> >
> >> > > > > >> > > Gowri,
> >> > > > > >> > >
> >> > > > > >> > > could you please share the steps you
have done to
> provision
> >> > the
> >> > > VM
> >> > > > > >> > manually
> >> > > > > >> > > and the SSH command to access it?
> >> > > > > >> > >
> >> > > > > >> > > ---
> >> > > > > >> > >
> >> > > > > >> > > Yes, I can manually provision VM with
the image (
> >> my-image-id)
> >> > > > and
> >> > > > > >> ssh
> >> > > > > >> > > > into it using my-keypair .
> >> > > > > >> > > >
> >> > > > > >> > >
> >> > > > > >> > > when you say using `my-keypair`, do you
mean, you want to
> >> use
> >> > > > > always a
> >> > > > > >> > > specific keypair already available on
your Openstack? By
> >> > > default,
> >> > > > > >> > Brooklyn
> >> > > > > >> > > will allocate a keypair for you, but
in case this is not
> >> the
> >> > > > > behavior
> >> > > > > >> you
> >> > > > > >> > > want, you can try the following YAML
at [1]
> >> > > > > >> > >
> >> > > > > >> > > Good luck,
> >> > > > > >> > > Andrea
> >> > > > > >> > >
> >> > > > > >> > > [1]:
> >> > > > > >> > https://gist.github.com/andreaturli/
> >> > > 33509ff74bb8d0cfb77d5ba36c4697
> >> > > > 7e
> >> > > > > >> > >
> >> > > > > >> >
> >> > > > > >> >
> >> > > > > >> >
> >> > > > > >>
> >> > > > > >
> >> > > > > >
> >> > > > >
> >> > > >
> >> > >
> >> >
> >>
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message